Bug 434617 - Compress::Zlib broken & fails to load
Compress::Zlib broken & fails to load
Status: CLOSED DUPLICATE of bug 434574
Product: Fedora
Classification: Fedora
Component: perl-Compress-Zlib (Show other bugs)
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-02-23 08:17 EST by Richard Kennedy
Modified: 2008-02-24 08:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-24 08:42:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Richard Kennedy 2008-02-23 08:17:30 EST
Description of problem:
any perl script using Compress::Zlib will not work or compile

Version-Release number of selected component (if applicable):
Version: 2.005
Release: 2.fc8

How reproducible:

Steps to Reproduce:
run a simple test perl script :-
use Compress::Zlib;
my $c = compress("test string");
Actual results:
compile errors :-
Use of uninitialized value in concatenation (.) or string at
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/Scalar/Util.pm line 30.
 is only avaliable with the XS version at
/usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9.
Compilation failed in require at /home/rsk/projects/junk/comp.pl line 6.
BEGIN failed--compilation aborted at /home/rsk/projects/junk/comp.pl line 6.

Expected results:
no errors!

Additional info:

I've marked this urgent as this bug is stopping my Slimserver music player from

This is the same as https://bugzilla.redhat.com/show_bug.cgi?id=434574 but much
more URGENT as I cannot play any of my music :(
Comment 1 Richard Kennedy 2008-02-24 07:43:51 EST
this issue is being discussed on perlmonks
Comment 2 Richard Kennedy 2008-02-24 07:47:34 EST
A fix / work-around for this is :-

>perl -MCPAN -eshell
>force install Scalar::Util

then everything works again. 
Comment 3 Gianluca Varisco 2008-02-24 08:42:36 EST

*** This bug has been marked as a duplicate of 434574 ***

Note You need to log in before you can comment on or make changes to this bug.