Bug 434602 - selinux message spam, boot hangs
selinux message spam, boot hangs
Product: Fedora
Classification: Fedora
Component: seedit (Show other bugs)
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Yuichi Nakamura
Fedora Extras Quality Assurance
: Reopened
: 433861 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-02-22 20:26 EST by Horst H. von Brand
Modified: 2009-07-14 14:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 14:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/Xor.0.log for failure (659.99 KB, text/plain)
2008-02-24 17:30 EST, Horst H. von Brand
no flags Details
Requested audit.log (after rebooting and doing other stuff) (2.56 MB, text/plain)
2008-02-28 15:26 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2008-02-22 20:26:14 EST
Description of problem:
When booting here (dual-core i686) I get hundreds of SELinux messages, that end

  udevd_event[...]: selinux_setfilecon: matchpathcon(/dev/dm-6)

and the boot hangs. I did a "fixfiles relabel" to make sure it isn't a SELinux
mislabeling problem, same result. SELinux is enabled, in Permissive mode. With 
kernel- the machine works fine (all later kernels don't work
for one reason or the other).

Nothing at all seems to make its way into /var/log/messages.

The almost exact same setup on x86_64 doesn't complain and works fine (modulo
gdm crashing).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Horst H. von Brand 2008-02-22 20:38:06 EST
*** Bug 433861 has been marked as a duplicate of this bug. ***
Comment 2 Horst H. von Brand 2008-02-23 17:56:18 EST
kernel-2.6.25-0.64.rc2.git5.fc9.i686 shows the same. As suggested in 433861 I
rebooted with "enforcing=0" (same result), then into the working
kernel- (last one that works here). "restorecon /" seems to
do nothing, and rebooting into the new kernel hangs again.

This system was migrated from Fedora 7 to rawhide when Fedora 8 was near, and
has been updated almost daily since.
Comment 3 Horst H. von Brand 2008-02-24 10:22:22 EST
Tried again, it is "just" that udev startup takes even ridiculously longer than
"restorecon -R /" gives thousands of messages like:

  restorecon set context
failed:'Invalid argument

This is both for files in my $HOME and system files (/usr/lib/*, etc).

With kernel-2.6.25-0.64.rc2.git5.fc9.i686 X fails to start.
Comment 4 Horst H. von Brand 2008-02-24 17:30:52 EST
Created attachment 295750 [details]
/var/log/Xor.0.log for failure

Still SELinux message spamming with kernel-2.6.25-0.65.rc2.git7.fc9.i686, X
fails to start. The log file is attached.
Comment 5 Daniel Walsh 2008-02-26 11:04:33 EST
What Filesystem are you using?
Comment 6 Horst H. von Brand 2008-02-28 07:48:04 EST
ext3 throughout
Comment 7 Horst H. von Brand 2008-02-28 07:51:55 EST
kernel-2.6.25-0.69.rc3.git1.fc9.i686 hangs (udev does fail to start, lots of
further SELinux messages, and then hang). Last message is:

  udevd_event[...]: selinux_setscreatecon: matchpathcon(/dev/sg1)

Comment 8 Daniel Walsh 2008-02-28 09:40:23 EST
Are you using upstart for init?

Can you boot in permissive mode?

Please attach the /var/log/audit/audit.log file
Comment 9 Horst H. von Brand 2008-02-28 15:26:50 EST
Created attachment 296254 [details]
Requested audit.log (after rebooting and doing other stuff)
Comment 10 Daniel Walsh 2008-02-28 15:47:50 EST
Please UNINSTALL seedit.  This package hammers all over selinux-policy package.

You might need to reinstall the selinux-policy package and relabel.

Or report this as a bug to the seedit people.
Comment 11 Horst H. von Brand 2008-02-29 08:28:09 EST
Yep, that fixed it. Many thanks, and sorry for wasting your time.

Shouldn't seedit be retired? This is then a severe bug in that package...
Comment 12 Daniel Walsh 2008-02-29 11:34:50 EST
I am reassigning to seedit.
Comment 13 Bug Zapper 2008-05-14 01:35:16 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 14 Bug Zapper 2009-06-09 19:37:10 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 15 Bug Zapper 2009-07-14 14:27:07 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.