Bug 434624 - Administrator Mode Not Working In KDE Control Center
Administrator Mode Not Working In KDE Control Center
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 431835 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 10:14 EST by Gerald Cox
Modified: 2008-03-24 06:58 EDT (History)
7 users (show)

See Also:
Fixed In Version: kdebase-3.5.9-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-24 06:58:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2008-02-23 10:14:37 EST
Description of problem:

Trying to activate Administrator mode within KDE Control Center to change KDE
Theme Manager and Login Manager.  When pressing "Administrator Mode" buttom,
receive popup "Run as root - KDE Su"; command "/usr/bin/kcmshell kdmtheme
--embed 58722095 --lan en_US" - when I enter the password, the popup goes away,
but nothing appears to happen.  Then when I logoff/login I receive another
message that this command needs the root password...I then enter, but again
nothing happens.

If I login as root, I am able to modify - however, I would prefer not to login
as root.


Version-Release number of selected component (if applicable):
kdebase-3.5.8-32.fc8


How reproducible:
See description above.


Steps to Reproduce:

See description above.
  
Actual results:
Nothing happens.


Expected results:
Enter administrative mode in KDE Theme Manager and Login Manager.


Additional info:
Comment 1 Lukáš Tinkl 2008-02-25 08:24:23 EST
Confirmed
Comment 2 Lukáš Tinkl 2008-02-25 11:44:02 EST
*** Bug 431835 has been marked as a duplicate of this bug. ***
Comment 3 Mary Ellen Foster 2008-02-26 10:30:52 EST
This seems to WORKFORME in kdebase-3.5.9-1.fc8, except that I get a popup after
entering the root password about being unable to create
/usr/local/share/apps/kdm/faces.
Comment 4 Mary Ellen Foster 2008-02-26 10:40:23 EST
(In reply to comment #3)
> I get a popup [ ... ] about being unable to create
> /usr/local/share/apps/kdm/faces.

This is, of course, bug 379781.
Comment 5 Gianluca Varisco 2008-03-23 07:37:01 EDT
Hi Mary Ellen,

bug 379781 has been closed as 'NOTABUG': see the comments on it for more details.

Regarding this bug, it WORKSFORME in kdebase-3.5.9-5.fc8. I'd say that we can
consider this bug closed, but before proceed I'd like to receive your feedback.
Comment 6 Mike C 2008-03-23 07:47:47 EDT
With the current version it works fine for me, though it may be worth mentioning
that some settings are not acted upon unless UseTheme=false is set in
/etc/kde/kdm/kdmrc

I am not the reporter of this bug but perhaps this helps before this bz is closed.
Comment 7 Gerald Cox 2008-03-24 05:44:28 EDT
Not sure exactly when this was corrected, but it is working fine now in 
kdebase-3.5.9-3.fc8

Note You need to log in before you can comment on or make changes to this bug.