Bug 434646 - xulrunner update fails.
xulrunner update fails.
Status: CLOSED DUPLICATE of bug 433096
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 17:01 EST by Gideon Mayhak
Modified: 2008-02-24 16:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-24 16:59:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gideon Mayhak 2008-02-23 17:01:19 EST
Description of problem:
When I try to update xulrunner, I receive the following error:

Error unpacking rpm package xulrunner-1.9-0.beta3.26.nightly20080222.fc9.i386
error: unpacking of archive failed on file
/usr/lib/xulrunner-1.9pre/dictionaries: cpio: rename

I believe this has been occurring with the last few updates, because my
currently installed version appears to be a few releases old
(xulrunner-1.9-0.beta3.20.nightly20080213.fc9.i386).  What's more, it does not
say the update failed, it actually says:

Updated: xulrunner.i386 0:1.9-0.beta3.26.nightly20080222.fc9
Complete!


Version-Release number of selected component (if applicable):
xulrunner.i386 0:1.9-0.beta3.26.nightly20080222.fc9 (and the past few updates)


How reproducible:
Every time I try to update xulrunner.


Steps to Reproduce:
yum update OR yum update xulrunner


Actual results:
development               100% |=========================| 2.4 kB    00:00     
primary.sqlite.bz2        100% |=========================| 5.9 MB    00:10     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.beta3.26.nightly20080222.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 xulrunner               i386       1.9-0.beta3.26.nightly20080222.fc9 
development       9.3 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 9.3 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): xulrunner-1.9-0.be 100% |=========================| 9.3 MB    00:17     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : xulrunner                    ######################### [1/2] 
Error unpacking rpm package xulrunner-1.9-0.beta3.26.nightly20080222.fc9.i386
error: unpacking of archive failed on file
/usr/lib/xulrunner-1.9pre/dictionaries: cpio: rename

Updated: xulrunner.i386 0:1.9-0.beta3.26.nightly20080222.fc9
Complete!


Expected results:
Properly updated xulrunner package.

Additional info:
I am running rawhide with all the latest updates, installed from the Alpha live CD.
Comment 1 Christopher Aillon 2008-02-24 16:59:35 EST
rpm -e --nodeps xulrunner
yum install xulrunner

*** This bug has been marked as a duplicate of 433096 ***

Note You need to log in before you can comment on or make changes to this bug.