Bug 434697 - Logitech USB wireless mouse stopped moving horizontal
Logitech USB wireless mouse stopped moving horizontal
Status: CLOSED DUPLICATE of bug 436692
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-02-24 11:06 EST by Mike Chambers
Modified: 2008-03-13 02:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-13 02:18:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg log (2.17 MB, application/octet-stream)
2008-02-26 10:39 EST, Dominick Grift
no flags Details
Xorg log (34.03 KB, application/octet-stream)
2008-02-26 10:39 EST, Dominick Grift
no flags Details
xorg.conf (600 bytes, application/octet-stream)
2008-02-26 10:40 EST, Dominick Grift
no flags Details
Xorg log with broken mouse (26.46 KB, text/plain)
2008-03-06 06:49 EST, Mike Chambers
no flags Details
Xorg Config file (599 bytes, application/octet-stream)
2008-03-06 06:49 EST, Mike Chambers
no flags Details

  None (edit)
Description Mike Chambers 2008-02-24 11:06:24 EST
Description of problem:After xorg updates couple days ago, my mouse will now 
only move vertically, but not horizonally while in GDM or Gnome desktop. Also 
can't use keyboard for control-alt-F or backspace button to get out.

Version-Release number of selected component (if applicable):

How reproducible:Everytime

Steps to Reproduce:
1.Upgrade to latest Xorg updates.
2.Boot to gdm or gnome desktop
3.Try to move mouse or use keyboard control-alt-F(1-9)
Actual results:Mouse only moves vertically.  Also keyboard doesn't respond to 
control-alt-Fkeys or backspace.

Expected results:Mouse/keyboard should work.

Additional info:Possibly related and/or same as the bug below...

Comment 1 Matěj Cepl 2008-02-25 16:40:17 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Dominick Grift 2008-02-26 10:35:19 EST
I also have the issue of my mouse not moving. However to me this only happens
when i load a game. On a normal gnome desktop session the mouse works fine, as
soon as i fire up UT2004 my mouse wont move left/right, only up/down

I am also using a logitec cordless desktop (not usb)
Comment 3 Dominick Grift 2008-02-26 10:39:09 EST
Created attachment 295938 [details]
xorg log
Comment 4 Dominick Grift 2008-02-26 10:39:54 EST
Created attachment 295939 [details]
Xorg log
Comment 5 Dominick Grift 2008-02-26 10:40:56 EST
Created attachment 295940 [details]
Comment 6 Mike Chambers 2008-03-04 07:07:37 EST
Is this the same problem as 434669?
Comment 7 Mike Chambers 2008-03-06 06:44:54 EST
Ok, upgraded to rawhide as of yesterday's updates.  Keyboard seemed to work (for
the most part) this time, but the mouse still only moved vertically and not
horizontally.  Have moved back to F8 but saved xorg.log and config from the
update and error.
Comment 8 Mike Chambers 2008-03-06 06:49:19 EST
Created attachment 297035 [details]
Xorg log with broken mouse
Comment 9 Mike Chambers 2008-03-06 06:49:45 EST
Created attachment 297036 [details]
Xorg Config file
Comment 10 Mike Chambers 2008-03-08 19:35:04 EST
Just a note, that I retried to install from rawhide today, but upon the first 
GUI screen, to click "Next" and start it, the mouse still only went vertically 
and not horizontally.  So something in the kernel, or something else is not 
correct, right off the bat.  I couldn't proceed with the install, so I exited.  
This was a clean install, or attempt, using anaconda, not yum.  Maybe this 
belongs to something else if not x involved at that point?
Comment 11 Mike Chambers 2008-03-12 06:04:58 EDT
Tried to install rawhide yesterday, and at least during the install, the mouse 
did work this time all throughout it.  Anaconda did a traceback at the end of 
package install, sometime during grub or after and didn't get to test out while 
in teh desktop.  So will know more in the next few days if this bug still 
Comment 12 Mike Chambers 2008-03-12 20:39:15 EDT
So far after the install (had same rhgb/upstart/selinux error everyone else
got), the mouse seems to work OK.  I think I have the same problem as everyone
else, as middle/right mouse buttons are reversed.
Comment 13 Matěj Cepl 2008-03-13 02:18:47 EDT
Thanks for letting us know.

*** This bug has been marked as a duplicate of 436692 ***

Note You need to log in before you can comment on or make changes to this bug.