Bug 436692 - Middle and right mouse buttons swapped after upgrade to evdev 1.99.1
Middle and right mouse buttons swapped after upgrade to evdev 1.99.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
hotissue
:
: 434697 436815 436853 437144 (view as bug list)
Depends On:
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-03-09 10:00 EDT by Joachim Frieben
Modified: 2008-03-13 02:18 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 19:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lshal command. (87.73 KB, text/plain)
2008-03-09 10:00 EDT, Joachim Frieben
no flags Details
xorg.conf of IBM ThinkPad T23 (459 bytes, text/plain)
2008-03-09 10:01 EDT, Joachim Frieben
no flags Details
Xorg.0.log of IBM ThinkPad T23 (40.87 KB, application/octet-stream)
2008-03-09 10:02 EDT, Joachim Frieben
no flags Details
Xorg.0.log of IBM ThinkPad T23 w/evdev driver 1.99.1 (40.51 KB, text/plain)
2008-03-09 10:08 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2008-03-09 10:00:49 EDT
Description of problem:
After upgrading to "rawhide" as of 2008-03-09, the middle button of
my 3-button PS/2 mouse connected to the port replicator of a closed
IBM ThinkPad T23 is disabled.

Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-1.99.1-0.1.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Update to evdev driver version 1.99.1.
2. Launch X.
3. Paste some text by pressing the middle mouse button.
  
Actual results:
None.

Expected results:
Text in buffer gets pasted to cursor position.

Additional info:
Downgrading to xorg-x11-drv-evdev-1.2.0-2.fc9 allows to restore proper
operation.
Comment 1 Joachim Frieben 2008-03-09 10:00:50 EDT
Created attachment 297357 [details]
Output of lshal command.
Comment 2 Joachim Frieben 2008-03-09 10:01:46 EDT
Created attachment 297358 [details]
xorg.conf of IBM ThinkPad T23
Comment 3 Joachim Frieben 2008-03-09 10:02:32 EDT
Created attachment 297359 [details]
Xorg.0.log of IBM ThinkPad T23
Comment 4 Joachim Frieben 2008-03-09 10:08:50 EDT
Created attachment 297360 [details]
Xorg.0.log of IBM ThinkPad T23 w/evdev driver 1.99.1
Comment 5 Joachim Frieben 2008-03-09 10:10:29 EDT
It turns out that the middle and right mouse buttons are simply swapped ..
Comment 6 Joachim Frieben 2008-03-09 13:20:25 EDT
Same issue on a desktop PC with a scroll mouse attached to the PS/2 port.
This bug should be added to the F9 blocker bug ..
Comment 7 Ralf Ertzinger 2008-03-09 15:44:48 EDT
"xmodmap -e 'pointer 1 3 2'" will temporarily fix this.
Comment 8 Ulrich Drepper 2008-03-09 18:27:13 EDT
Probably a generic bug.  In case not, I see it on my X61 as well.
Comment 9 Rene Rask 2008-03-09 22:50:04 EDT
I can confirm this on my Lenovo T61p. Buttons are swapped.
On my Toshiba Qosmio it doesn't happen.
Comment 10 Joachim Frieben 2008-03-10 05:24:12 EDT
(In reply to comment #7)
> "xmodmap -e 'pointer 1 3 2'" will temporarily fix this.

xmodmap -e 'pointer 1 3 2'
xmodmap:  commandline:1:  bad buttons pointer code list, missing equal sign
xmodmap:  1 error encountered, aborting.
Comment 11 Joachim Frieben 2008-03-10 05:26:25 EDT
(In reply to comment #7)
> "xmodmap -e 'pointer 1 3 2'" will temporarily fix this.

xmodmap -e 'pointer = 1 3 2'
Warning: Only changing the first 3 of 32 buttons.

This command does the job.
Comment 12 Hans de Goede 2008-03-10 06:16:35 EDT
Me too, pretty standard desktop pc, with logitech imps/2 mouse.
Comment 13 Thomas Woerner 2008-03-10 13:04:36 EDT
*** Bug 436815 has been marked as a duplicate of this bug. ***
Comment 14 Will Woods 2008-03-10 16:15:31 EDT
*** Bug 436853 has been marked as a duplicate of this bug. ***
Comment 15 Patrick 2008-03-10 19:31:42 EDT
FWIW with today's Rawhide I can no longer use my Synaptic touchpad as a button
by tapping it twice. I tried the xmodmap suggestion in #7 but touchpad is still
unusable as a button. The 2 right hardbuttons above and under my touchpad also
no longer work. Normal mouse moving with the touchpad works fine afaict.
Comment 16 José Matos 2008-03-11 10:37:06 EDT
  FWIW I found that for my usb mouse if I detach the mouse and then reconnect
it again the buttons order is restored. :-)
Comment 17 Adam Jackson 2008-03-11 19:27:00 EDT
Fixed in xorg-x11-drv-evdev 1.99.1-0.3.fc9.
Comment 18 Will Woods 2008-03-12 15:37:28 EDT
*** Bug 437144 has been marked as a duplicate of this bug. ***
Comment 19 Matěj Cepl 2008-03-13 02:18:48 EDT
*** Bug 434697 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.