Bug 434720 - Invalid package set after upgrade from FC6 to FC9-Alpha
Invalid package set after upgrade from FC6 to FC9-Alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-02-24 18:31 EST by Trevin Beattie
Modified: 2008-04-18 02:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 21:35:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm package list and verification report (185.90 KB, application/octet-stream)
2008-02-24 18:31 EST, Trevin Beattie
no flags Details
Set of log files following the failed upgrade (1.37 MB, application/octet-stream)
2008-02-24 22:55 EST, Trevin Beattie
no flags Details
Upgrade logs and anaconda crash dump. (72.57 KB, application/octet-stream)
2008-03-08 16:47 EST, Trevin Beattie
no flags Details
Package list and verification report (13.37 KB, application/octet-stream)
2008-03-08 16:48 EST, Trevin Beattie
no flags Details
Upgrade logs, anaconda crash dump, and rpm verification report for fc9b (78.19 KB, application/octet-stream)
2008-04-18 02:17 EDT, Trevin Beattie
no flags Details

  None (edit)
Description Trevin Beattie 2008-02-24 18:31:59 EST
Description of problem:
I performed a trial upgrade from FC6 to FC9-Alpha on a virtual machine.  Besides
the problem with the /boot partition not being upgraded (bug #434716), I'm
finding that many packages were not properly upgraded at all -- the old packages
are still listed in the rpm database, and many of the new packages are missing
dependencies.  The first problem I'm seeing is that X will not start because
xorg-x11-server-Xorg was not upgraded but some of the drivers were, causing a
version mismatch.

Version-Release number of selected component (if applicable):
anaconda-11.4.0.28-1

How reproducible:
Only tried once so far; the upgrade takes about an hour.

Steps to Reproduce:
1. Install FC6 using the default partition layout and most package groups.  You
may need at least 10GB of disk space.
2. Boot the FC9 Alpha install DVD and upgrade the existing installation.
3. Reboot the FC9 Alpha install DVD again, copy the files from /boot on the root
partition to the boot partition (see bug #434716), and add the new kernel to
grub.conf.
3. Reboot.

Actual results:
X will not start.  The log shows:

(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 1.4.0.1, module version = 1.2.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0
(EE) module ABI major version (2) doesn't match the server's version (0)
(II) UnloadModule: "kbd"
(II) Unloading /usr/lib/xorg/modules/input/kbd_drv.so
(EE) Failed to load module "kbd" (module requirement mismatch, 0)

'rpm -qf /usr/lib/xorg/modules/input/kbd_drv.so' shows:
xorg-x11-drv-keyboard-1.1.0-2.1
xorg-x11-drv-keyboard-1.2.2-3.fc9

'rpm -V xorg-x11-drv-keyboard-1.2.2-3.fc9' shows:
Unsatisfied dependencies for xorg-x11-drv-keyboard-1.2.2-3.fc9.i386:
xorg-x11-server-Xorg >= 1.4.99.1

'rpm -q xorg-x11-server-Xorg' shows:
xorg-x11-server-Xorg-1.1.1-47.fc6


Expected results:
xorg-x11-drv-keyboard-1.1.0-2.1 should have been removed.
xorg-x11-server-Xorg-1.1.1-47.fc6 should have been upgraded to
xorg-x11-server-Xorg-1.4.99.1-0.18.20080107.fc9.
Likewise all existing packages which have newer versions should have been
upgraded and the old version removed.

Additional info:
Comment 1 Trevin Beattie 2008-02-24 18:31:59 EST
Created attachment 295754 [details]
rpm package list and verification report
Comment 2 Jeremy Katz 2008-02-24 19:43:14 EST
Can you attach /var/log/anaocnda.log and /root/upgrade.log?
Comment 3 Trevin Beattie 2008-02-24 22:55:44 EST
Created attachment 295762 [details]
Set of log files following the failed upgrade

Yeah, but it's several megabytes long, and I didn't see anything in it that
looked useful...
Comment 4 Jeremy Katz 2008-03-02 12:27:42 EST
Did you have SELinux enabled on the system before doing the upgrade?
Comment 5 Trevin Beattie 2008-03-02 16:42:01 EST
SELinux Setting: Disabled
Comment 6 Jeremy Katz 2008-03-02 16:50:16 EST
If you have a snapshot and can try, can you try adding 'selinux=0' to the kernel
command line when you boot the installer to do the upgrade?  I suspect that this
has returned (... or our detection of SELinux being disabled doesn't work
against FC6 for some reason)
Comment 7 Trevin Beattie 2008-03-08 16:46:08 EST
I managed to bypass bug #434716 by manually mounting
/mnt/sysimage/boot from VT2 while anaconda was checking installed
package information for dependencies.  By this time it had already
overwritten /etc/fstab, so I re-added the entry for /boot as well.

The upgrade got as far as "finishing the upgrade process", where it
got stuck for at least half an hour on package 1201 out of 1202.
Finally an exception occurred:

INFO    : moving (1) to step postinstallconfig
INFO    : moving (1) to step instbootloader
INFO    : vg VolGroup00, size is 16032, pesize is 32768
CRITICAL: anaconda 11.4.0.28 exception report
Traceback (most recent call first):
  File "/usr/lib/booty/bootloaderInfo.py", line 759, in writeGrub
    f.write('#          root %s\n' % self.grubbyPartitionName(bootDevs[0]))
  File "/usr/lib/booty/bootloaderInfo.py", line 1187, in write
    justConfig | (not self.useGrubVal))
  File "/usr/lib/anaconda/bootloader.py", line 209, in writeBootLoader
    justConfigFile, anaconda.intf)
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 132 in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 652, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1065, in <module>
    anaconda.intf.run(anaconda)
IndexError: list index out of range

On reboot, I was met with the "grub> " CLI prompt.  Turns out that the grub.conf
file had been truncated.  So I created a bare-bones configuration from scratch
and tried booting again.

On the positive side, there were much fewer errors this time around.  The
upgrade log is much shorter this time.  There's also an anaconda dump.

It seems most packages were successfully updated.  Only a few packages failed
verification, including a few system packages, some packages from Fedora Extras,
and one or two custom packages.
Comment 8 Trevin Beattie 2008-03-08 16:47:46 EST
Created attachment 297332 [details]
Upgrade logs and anaconda crash dump.

The install.log file is unchanged from the first tarball.
Comment 9 Trevin Beattie 2008-03-08 16:48:34 EST
Created attachment 297333 [details]
Package list and verification report
Comment 10 Jeremy Katz 2008-04-08 14:08:04 EDT
I think this should be fixed for the preview release.  There were a few places
in booty that were ... "confused" as far as what bootDevs meant but we've gone
through and at least in theory cleaned them all up
Comment 11 Jon Stanley 2008-04-14 21:35:18 EDT
Just did a FC6->F9 upgrade and it seems to be fine - boots into X, etc, no need
to copy stuff around, etc

Closing
Comment 12 Trevin Beattie 2008-04-18 02:15:35 EDT
I don't see where I would get the preview release, but I finally got the beta
release downloaded (after a whole lot of network problems --
http://forums.nvidia.com/index.php?showtopic=64926) and tried another upgrade. 
It failed again -- anaconda crashed during the last package of "finishing the
upgrade process".  Two dozen old FC6 packages were left after rebooting, but on
inspection it looks like there were no new versions of any of these packages
except avahi, and the upgrade.log shows that there was a segmentation fault
during the %postun(avahi-0.6.11-6.fc6) scriplet.
Comment 13 Trevin Beattie 2008-04-18 02:17:30 EDT
Created attachment 302841 [details]
Upgrade logs, anaconda crash dump, and rpm verification report for fc9b

Note You need to log in before you can comment on or make changes to this bug.