Bug 434760 - F-9 pv_ops: recursive locking warning during x86_32 DomU boot
F-9 pv_ops: recursive locking warning during x86_32 DomU boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
: 438707 (view as bug list)
Depends On:
Blocks: PvOpsTracker
  Show dependency treegraph
 
Reported: 2008-02-25 05:54 EST by Mark McLoughlin
Modified: 2008-03-25 13:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 13:28:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2008-02-25 05:54:06 EST
Seeing this with kernel-xen-2.6.24-23.7.pv_ops during DomU boot:

Red Hat nash version 6.0.29 starting
Mounting proc filesystem
Mounting sysfs filesystem
Creating /dev
Creating initial device nodes
Setting up hotplug.

=============================================
[ INFO: possible recursive locking detected ]
2.6.24-23.7.pv_ops.fc9xen #1
---------------------------------------------
init/1 is trying to acquire lock:
 (__pte_lockptr(new)){--..}, at: [<c10047c4>] pin_page+0x6c/0x12d

but task is already holding lock:
 (__pte_lockptr(new)){--..}, at: [<c10047c4>] pin_page+0x6c/0x12d

other info that might help us debug this:
4 locks held by init/1:
 #0:  (&mm->mmap_sem){----}, at: [<c10336c7>] copy_process+0xa7f/0x1306
 #1:  (&mm->mmap_sem/1){--..}, at: [<c10336dd>] copy_process+0xa95/0x1306
 #2:  (&mm->page_table_lock){--..}, at: [<c1004998>] xen_dup_mmap+0x11/0x24
 #3:  (__pte_lockptr(new)){--..}, at: [<c10047c4>] pin_page+0x6c/0x12d

stack backtrace:
Pid: 1, comm: init Not tainted 2.6.24-23.7.pv_ops.fc9xen #1
 [<c100bb70>] show_trace+0x1a/0x32
 [<c1255813>] _etext+0x6c/0x72
 [<c105290f>] __lock_acquire+0x8fe/0xc5b
 [<c1052ce7>] lock_acquire+0x7b/0x9e
 [<c12518a6>] _spin_lock+0x2e/0x58
 [<c10047c4>] pin_page+0x6c/0x12d
 [<c1003a94>] pgd_walk+0x119/0x162
 [<c10048c7>] xen_pgd_pin+0x42/0x102
 [<c10049a0>] xen_dup_mmap+0x19/0x24
 [<c10338af>] copy_process+0xc67/0x1306
 [<c1033f77>] do_fork+0x29/0x19e
 [<c100778b>] sys_clone+0x2f/0x31
 [<c100917a>] syscall_call+0x7/0xb
 =======================
Creating block device nodes.
Loading ehci-hcd module
Comment 1 Mark McLoughlin 2008-03-25 04:21:56 EDT
*** Bug 438707 has been marked as a duplicate of this bug. ***
Comment 2 Mark McLoughlin 2008-03-25 12:01:11 EDT
Note, this is only visible on x86_32
Comment 3 Mark McLoughlin 2008-03-25 13:28:12 EDT
Seems this is a harmless warning:

  http://lkml.org/lkml/2008/3/20/273

Hopefully upstream will figure out a way to avoid the warning, but there's no
point in keeping this bug open to track the issue.

Note You need to log in before you can comment on or make changes to this bug.