Bug 438707 - INFO: possible recursive locking detected
INFO: possible recursive locking detected
Status: CLOSED DUPLICATE of bug 434760
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-24 12:51 EDT by Orion Poplawski
Modified: 2009-12-14 15:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 04:21:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-03-24 12:51:14 EDT
Description of problem:

=============================================
[ INFO: possible recursive locking detected ]
2.6.25-0.4.rc4.fc9xen #1
---------------------------------------------
init/1 is trying to acquire lock:
 (__pte_lockptr(page)){--..}, at: [<c0404d39>] pin_page+0x6f/0x137

but task is already holding lock:
 (__pte_lockptr(page)){--..}, at: [<c0404d39>] pin_page+0x6f/0x137

other info that might help us debug this:
4 locks held by init/1:
 #0:  (&mm->mmap_sem){----}, at: [<c042a40f>] copy_process+0xa9e/0x13fb
 #1:  (&mm->mmap_sem/1){--..}, at: [<c042a425>] copy_process+0xab4/0x13fb
 #2:  (&mm->page_table_lock){--..}, at: [<c0404f14>] xen_dup_mmap+0x11/0x24
 #3:  (__pte_lockptr(page)){--..}, at: [<c0404d39>] pin_page+0x6f/0x137

stack backtrace:
Pid: 1, comm: init Not tainted 2.6.25-0.4.rc4.fc9xen #1
 [<c04485e2>] __lock_acquire+0x8ef/0xc11
 [<c044896e>] lock_acquire+0x6a/0x90
 [<c0404d39>] ? pin_page+0x6f/0x137
 [<c0641b6a>] _spin_lock+0x1c/0x49
 [<c0404d39>] ? pin_page+0x6f/0x137
 [<c0404d39>] pin_page+0x6f/0x137
 [<c0404633>] pgd_walk+0x12f/0x178
 [<c0404cca>] ? pin_page+0x0/0x137
 [<c0404e43>] xen_pgd_pin+0x42/0x102
 [<c0404f1c>] xen_dup_mmap+0x19/0x24
 [<c042a5f5>] copy_process+0xc84/0x13fb
 [<c042ae1b>] do_fork+0xaf/0x1e4
 [<c048cc39>] ? vfs_write+0xf0/0x12e
 [<c0408c49>] ? restore_nocheck+0x12/0x15
 [<c040740f>] sys_clone+0x1f/0x21
 [<c0408bda>] syscall_call+0x7/0xb
 =======================

x86_32 rawhide guest on x86_64 F-8 host.
Comment 1 Mark McLoughlin 2008-03-25 04:21:54 EDT

*** This bug has been marked as a duplicate of 434760 ***

Note You need to log in before you can comment on or make changes to this bug.