Bug 434773 - imsettings-reload gets SIGABRT and breaks gdm logging
imsettings-reload gets SIGABRT and breaks gdm logging
Status: CLOSED DUPLICATE of bug 436284
Product: Fedora
Classification: Fedora
Component: im-chooser (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 07:12 EST by Adam Tkac
Modified: 2013-04-30 19:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 12:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xsession-errors file (1.40 KB, text/plain)
2008-03-17 04:59 EDT, Adam Tkac
no flags Details
output from imsettings-reload (1.26 KB, text/plain)
2008-03-17 05:01 EDT, Adam Tkac
no flags Details

  None (edit)
Description Adam Tkac 2008-02-25 07:12:25 EST
Description of problem:
imsettings-reload -f gets sigabrt and after that logging to graphical session is
broken (tested with both kdm and gdm)

Version-Release number of selected component (if applicable):
0.99.3-1.fc9

How reproducible:
always

Steps to Reproduce:
1. install imsettings
2. try log into your desktop
3. it looks like logging hangs
  
Actual results:
login to desktop doesn't work

Expected results:
logging works fine

Additional info:
when I remove imsettings-libs package (so imsettings is also removed) logging
starts work again (and if I install it logging stops work). Let me know if you
need more info (core file etc)
Comment 1 Akira TAGOH 2008-02-25 21:50:55 EST
Could you please give me more details for that? I have yum-upgrade on my rawhide
box and tried to log into my desktop. I can log into it and imsettings-reload -f
works fine also.

I have tested with:
gdm-2.21.7-1.fc9
dbus-1.1.4-6.fc9
dbus-glib-0.74-3.fc9

It would be helpful if you can give me any warnings or errors with
imsettings-reload and logs in .xsession-errors.
Comment 2 Adam Tkac 2008-03-17 04:59:57 EDT
Created attachment 298244 [details]
xsession-errors file
Comment 3 Adam Tkac 2008-03-17 05:01:05 EDT
Created attachment 298245 [details]
output from imsettings-reload
Comment 4 Adam Tkac 2008-03-17 05:02:52 EDT
Sorry for my late response, needed files are attached. If you need core dump let
me know.
Comment 5 Akira TAGOH 2008-03-19 07:04:39 EDT
Thanks. well, it looks like getting the shared connection failed on your box.
which is weird. are you sure you have a dbus process running for the session bus?

The session bus should be launched first according to the sort order of
/etc/X11/xinit/xinitrc.d.
Comment 6 Akira TAGOH 2008-03-27 04:09:52 EDT
simply doing echo /etc/X11/xinit/xinitrc.d/* would shows me what's really wrong
maybe. guess the root cause of this issue may be the same to what I have written
in Bug#436284.
Comment 7 Adam Tkac 2008-03-27 12:25:31 EDT
(In reply to comment #6)
> simply doing echo /etc/X11/xinit/xinitrc.d/* would shows me what's really wrong
> maybe. guess the root cause of this issue may be the same to what I have written
> in Bug#436284.

Yes, this one is duplicate of #436284. I would never guess that problem might be
in locale. Closing

*** This bug has been marked as a duplicate of 436284 ***

Note You need to log in before you can comment on or make changes to this bug.