Bug 436284 - Gnome session doesn't start with default cs_CZ locale
Summary: Gnome session doesn't start with default cs_CZ locale
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: im-chooser   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 434773 (view as bug list)
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2008-03-06 11:37 UTC by Matěj Cepl
Modified: 2018-04-11 16:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 12:01:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matěj Cepl 2008-03-06 11:37:32 UTC
Description of problem:
I have to switch to other locale than my default cs_CZ in order to start
gnome-session. Tried en_IE (which unfortunately started in non-UTF8 mode which
is pretty broken for me) and now happily using en_DK (which is UTF8). startx
does start with cs_CZ with "exec /usr/bin/gnome-session" in ~/.xinitrc.

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.4.99.900-0.28.20080304.fc9.x86_64
xorg-x11-drv-ati-6.8.0-3.fc9.x86_64
gnome-session-2.21.92-1.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.900-0.28.20080304.fc9.x86_64

How reproducible:
100%

Comment 1 Ray Strode [halfline] 2008-03-06 19:05:07 UTC
what version of gdm are you running?  We fixed a number of serious problems in
language selection recently.

Comment 2 Matěj Cepl 2008-03-06 21:35:37 UTC
gdm-2.21.9-0.2008.02.29.1.fc9.x86_64

Comment 3 Matthias Clasen 2008-03-25 17:08:42 UTC
Matej, do you still have this problem with newer gdm snapshots ?


Comment 4 Matěj Cepl 2008-03-25 17:59:31 UTC
yup, live and kicking! Apparently notting was able to reproduce as well.

Comment 5 Ray Strode [halfline] 2008-03-25 18:13:48 UTC
Talked with mcepl and notting about this on irc today.  Apparently uninstalling
im-chooser makes things work, so it's blocking start up.

Reassigning.

Comment 6 Akira TAGOH 2008-03-26 02:50:26 UTC
Sure. confirmed. looking into it.

Comment 7 Akira TAGOH 2008-03-26 08:25:05 UTC
Okay, I see why I have never seen this issue on my box. this should be gone
since dbus daemon has been launched from
/etc/X11/xinit/xinitrc.d/00-start-message-bus.sh. and should be supposed to get
it first rather than alphabetical filenames. however the result of picking
filenames up with the wild-card or the kind of sort depends on current locale.
in your case, the alphabetical filenames appears first. so actually imsettings
is bringing up before starting. which requires the session bus.

I have decided to rename xinput.sh to 99-xinput.sh say to ensure the process
order in xinitrc.d anyway.

Comment 8 Adam Tkac 2008-03-27 16:25:32 UTC
*** Bug 434773 has been marked as a duplicate of this bug. ***

Comment 9 Akira TAGOH 2008-03-28 06:30:45 UTC
Fixed in 0.99.5-2.fc9.

Comment 10 Adam Tkac 2008-04-16 12:01:01 UTC
(In reply to comment #9)
> Fixed in 0.99.5-2.fc9.

Confirmed.


Note You need to log in before you can comment on or make changes to this bug.