Bug 434774 - Firefox doesn't like Beagle Indexer
Firefox doesn't like Beagle Indexer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 07:13 EST by Horst H. von Brand
Modified: 2008-04-28 15:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 15:41:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-02-25 07:13:37 EST
Description of problem:
When starting firefox, I get a dialog window with:

  The following items were found in your Extensions folder. Do you want to
install them?

  Beagle Indexer (Author Unknown)
 
file:///usr/lib/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/beagle.xpi

Version-Release number of selected component (if applicable):
beagle-0.3.3-6.fc9.i386
firefox-3.0-0.beta3.27.nightly20080223.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Start firefox
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Nielsen 2008-02-25 10:52:37 EST
I have noticed this as well, my first guess was that the addon support in
Firefox currently is in flux due to it being in beta. However I cannot seem to
figure out how to make Firefox tell me where it hurts.. no terminal output, the
firefox error console doesn't appear helpful either. I am forced to cc callion
here for help.

I have also long wanted to make this plugin optional for those of us who don't
use or like Firefox so starting with revision 8 of the Beagle package this can
now be found in beagle-firefox.
Comment 2 Horst H. von Brand 2008-02-28 14:35:45 EST
Seems to be gone with firefox-3.0-0.beta3.29.nightly20080227.fc9.i386
Comment 3 Christopher Aillon 2008-03-02 14:23:06 EST
I bet this was a bug in the .xpi stuff.  In retrospect, and in honesty, we
should probably not ship xpi extensions where we can help it.  Unpacking it into
$extension_id makes firefox not think of installing it in general, and it gives
a performance win.

So, simply unzip the xpi and place its contents into a directory containing its
extension ID which would be either a UUID or something like beagle@gnome.org

Looking at install.rdf:
8     <em:id>{fda00e13-8c62-4f63-9d19-d168115b11ca}</em:id>

But also:
21     <em:targetApplication>
22       <Description>
23         <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
24         <em:minVersion>0.8</em:minVersion>
25         <em:maxVersion>2.0.*</em:maxVersion>
26       </Description>
27     </em:targetApplication>

Which makes me wonder if this is even useful to ship right now since it's
maxVersion claim will mean Firefox won't even load it (or it shouldn't at least).
Comment 4 David Nielsen 2008-03-02 16:30:48 EST
I'll exclude for development till upstream clearly supports the version of
Firefox we ship.
Comment 5 Dominik Sandjaja 2008-04-23 08:27:43 EDT
Bug #442511 is a duplicate of this. And why is beagle-firefox still in the
rawhide-repository?
Comment 6 David Nielsen 2008-04-23 10:12:43 EDT
an updated firefox plugin was posted to the beagl mailing list, it should find
it's way to you shortly I am sure. 
Comment 7 Adel Gadllah 2008-04-28 15:41:44 EDT
Fixed in beagle-0.3.7-3.fc9, should hit the next rawhide push.

Note You need to log in before you can comment on or make changes to this bug.