Bug 434802 - xenkbd can deadlock virtual keyboard on resume
xenkbd can deadlock virtual keyboard on resume
Status: CLOSED DUPLICATE of bug 434800
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
All Linux
high Severity high
: rc
: ---
Assigned To: Markus Armbruster
Martin Jenner
:
Depends On:
Blocks: 434800 434806 448753 451807
  Show dependency treegraph
 
Reported: 2008-02-25 11:23 EST by Markus Armbruster
Modified: 2008-07-21 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 12:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (1.83 KB, patch)
2008-02-26 10:11 EST, Markus Armbruster
no flags Details | Diff

  None (edit)
Description Markus Armbruster 2008-02-25 11:23:01 EST
Description of problem:
xenkbd_resume() fails to reinitialize the shared page.  If the driver resumes
with a full ring buffer, it deadlocks: the frontend won't drain the ring buffer
until notified through the event channel, and the backend won't notify while the
ring buffer is full.

How reproducible:
Haven't tried.

Additional info:
Upstream fix: http://xenbits.xensource.com/linux-2.6.18-xen.hg?rev/90fbf541d772
Comment 1 Markus Armbruster 2008-02-26 09:17:44 EST
It should be possible to trigger the bug by moving the mouse in the guest's
virtual screen during save.

You need to reinitialize the device to get it unstuck.  Reboot works.  Maybe
driver unbind / bind could also work, but when I tried it, the device
reinitialized as /class/input/input2, and X was not happy.
Comment 2 Markus Armbruster 2008-02-26 09:18:52 EST
Clarification: rebooting the *guest* works.  No need to reboot the host.
Comment 3 Markus Armbruster 2008-02-26 10:11:13 EST
Created attachment 295929 [details]
Proposed fix

Addresses bug 434800 and bug 434806 as well.

XS upstream fixed bug 434802 in
http://xenbits.xensource.com/linux-2.6.18-xen.hg?rev=415
That fix clears just the defined members of the shared page.  My patch clears
the whole shared page, both on probe and resume.  Makes more sense, and matches
the framebuffer device's behavior.
Comment 4 RHEL Product and Program Management 2008-06-09 17:58:43 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Markus Armbruster 2008-07-21 12:26:28 EDT
The patch in comment#3 also addresses bug 451807.
Comment 7 Markus Armbruster 2008-07-21 12:45:39 EDT
The proposed fix has been committed as a fix for bug 434800.  Turning this one
into a duplicate of 434800 to keep things simple and sane.

*** This bug has been marked as a duplicate of 434800 ***

Note You need to log in before you can comment on or make changes to this bug.