Bug 434806 - xenfb can crash when probe fails
xenfb can crash when probe fails
Status: CLOSED DUPLICATE of bug 434800
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
All Linux
low Severity medium
: rc
: ---
Assigned To: Markus Armbruster
Martin Jenner
Depends On: 434802
Blocks: 448753
  Show dependency treegraph
Reported: 2008-02-25 11:32 EST by Markus Armbruster
Modified: 2008-07-21 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-07-21 12:43:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2008-02-25 11:32:08 EST
Description of problem:
xenfb_probe() dereferences null info->fb_info when register_framebuffer() fails.

How reproducible:
Haven't tried.
Comment 1 Markus Armbruster 2008-02-26 09:33:21 EST
register_framebuffer() fails when FB_MAX framebuffers are already registered.  I
doubt this can happen, because the device is compiled in and thus probes fairly

When the bug bites, the driver dereferences a null pointer during cleanup from
the failed probe.
Comment 2 Markus Armbruster 2008-02-26 10:12:15 EST
See bug 434802 for a proposed fix.
Comment 3 RHEL Product and Program Management 2008-06-09 17:58:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 5 Markus Armbruster 2008-07-21 12:43:52 EDT
The proposed fix from bug 434802 has been committed as a fix for bug 434800. 
Turning this one into a duplicate of 434800 to keep things simple and sane.

*** This bug has been marked as a duplicate of 434800 ***

Note You need to log in before you can comment on or make changes to this bug.