This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 434899 - Shutdown happens on wrong screen
Shutdown happens on wrong screen
Status: CLOSED DUPLICATE of bug 439699
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 23:29 EST by Ray Todd Stevens
Modified: 2014-03-16 23:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 14:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-02-25 23:29:27 EST
I have an interesting problem.   Running the current raw hide and in some cases
the wrong virtual screen contains the shutdown stuff.   If I use the menu
optiojs everything works hunk dorry.   But if I goto a terminal su and run
shutdown then the little display of the progress of the shutdown happens on the
wrong screen.

If you go to a terminal first by doing ctrl alt f1 and then login and rung
shutdown everything is ok.   But if you run it from a terminal box in xwindows
the xwindows system pretty immediately shuts down and you are switched to
virtual screen ctrl alt f1,   But nothing happens on this screen.   Instead the
shutdown process is hidden on screen ctrl alt f7.  

Now if the screen f1 said "system shutting" or "system rebooting" while hiding
the details that might be real cool.  This might even make for a cool rfe.   But
that is not what happens.   Instead it looks like everything hung.
Comment 1 Bill Nottingham 2008-02-26 15:06:47 EST
Is this in the context of upstart, or with normal init?
Comment 2 Ray Todd Stevens 2008-02-26 15:15:40 EST
I am not sure what you are asking.    

This has to do with the way that the init scripts run during shutdown not startup.

Specifically it has to do with what happens if you run the shutdown program from
an x windows terminal.   It is also a change in the way things worked from the
previous versions.
Comment 3 Ray Todd Stevens 2008-03-09 18:24:12 EDT
I have bene playing with this.   I can't seem to find a way to fix it from my
end.  As I said this is a big user interface issue between fc8 and fc9.   You
will also note that this is not an issue with starting but in what happens when
you do a shutdown/halt or a reboot.

Right now in fc8 when you execute any of the means of shutdown then the logging
of the shutdown happens in screen 1 (tty1)  ctrl alt f1.   This means that when
a user choses to halt or reboot that the user gets an indication something is
happening.   Now in many cases all that happens is that the user sees a text
login prompt and nothing else for a period of several minutes.   For a user who
is used to the past process this would be an indication that there is something
wrong.

Part of this might have to do with another change in the system.   It used to be
that at a graphic xwindows screen you could switch to a text interface by doing
ctrl alt f1(tru f6).   You can no longer do this.  Instead you are locked into
xwindows.  This is probably a good thing, but it may also need to be mentioned
in the documentation of differences between versions.

The problem is that now if you do a shutdown from the xwindows login screen, the
xwindows menu, or by brining up a terminal and running shutdown you get the same
result.   That results is that a text screen with a login prompt will be
displayed.   That login prompt will work for a while, and then in the middle of
doing something like trying to find out what is happening you will be dropped
out to a totally blank screen like a hot potato trying to figure out why the
hardware is malfunctioning.  Instead of seeing the progress of the
shutdown/reboot here as has been then the past procedure it is hidden on a
screen which should not even exist ctrl alt f7.

This may indeed be a problem in either the init routine itself or in xwindows. 
If you are using a run level 3 then every thing works as expected.

Now this change will cause much confusion to the users.   My preferred fix here
would be to keep the login diagnostics hidden from the users.   Instead to do
two things.   

a.   during shutdown immediately disable logins (this also used to happen and no
longer does :-(  )

b.   Output a message to all of the ttys that the shutdown/reboot is happening
and to please wait.   This also used to happen pre fc4 but doesn't in the
current releases.

Then the actual technical bits would be invisible unless you knew the open
secret and purposefully brought them up.

However bring it back to the fc8 status would also work if that is faster so we
can get the release out.   I do think that over the long term a/b would should
be implemented.

Comment 4 Bill Nottingham 2008-03-10 13:11:45 EDT
(In reply to comment #3)
> Part of this might have to do with another change in the system.   It used to be
> that at a graphic xwindows screen you could switch to a text interface by doing
> ctrl alt f1(tru f6).   You can no longer do this.  Instead you are locked into
> xwindows.  This is probably a good thing, but it may also need to be mentioned
> in the documentation of differences between versions.

This is just a generic X bug. Until this is fixed, I'm not sure further
debugging is useful.
Comment 5 Will Woods 2008-04-02 13:44:47 EDT
This happens on some of my F8 systems as well. It's not upstart-specific, as far
as I know.
Comment 6 Bug Zapper 2008-05-14 01:38:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Ray Todd Stevens 2008-07-01 14:49:44 EDT
Definitely still a problem with production 9.   Have seen if I could come up
with a patch, but it looks like changes are needed places I really can't get to.
Comment 8 David Rees 2008-07-23 14:18:23 EDT
Look at bug 439280 and bug 439699, they are both duplicates of this one and
contain more information. All three bugs should probably be merged.
Comment 9 Bill Nottingham 2008-07-23 14:22:59 EDT

*** This bug has been marked as a duplicate of 439699 ***

Note You need to log in before you can comment on or make changes to this bug.