Bug 435035 - Asterisk fails to build on PPC64
Asterisk fails to build on PPC64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: asterisk (Show other bugs)
rawhide
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-ExcludeArch-ppc64/F-ExcludeArch-ppc64
  Show dependency treegraph
 
Reported: 2008-02-26 17:49 EST by Jeffrey C. Ollie
Modified: 2008-02-26 23:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 23:56:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Ollie 2008-02-26 17:49:11 EST
Asterisk fails to build on PPC64, see:

http://koji.fedoraproject.org/koji/taskinfo?taskID=471934
Comment 1 David Woodhouse 2008-02-26 19:13:31 EST
That's a very strange failure... I see no output from gcc explaining what broke:

make[2]: Leaving directory
`/builddir/build/BUILD/asterisk-1.6.0-beta4/main/minimime'
gcc  -o asterisk -Wl,--export-dynamic   abstract_jb.o acl.o adsistub.o
aescrypt.o aeskey.o aestab.o alaw.o app.o ast_expr2.o ast_expr2f.o asterisk.o
astmm.o astobj2.o audiohook.o autoservice.o callerid.o cdr.o channel.o
chanvars.o cli.o config.o cryptostub.o db.o devicestate.o dial.o dns.o dnsmgr.o
dsp.o enum.o event.o features.o file.o fixedjitterbuf.o frame.o fskmodem.o
global_datastores.o hashtab.o http.o image.o indications.o io.o jitterbuf.o
libresample/src/filterkit.o libresample/src/resample.o
libresample/src/resamplesubs.o loader.o logger.o manager.o md5.o netsock.o pbx.o
plc.o privacy.o rtp.o say.o sched.o sha1.o slinfactory.o srv.o
stdtime/localtime.o strcompat.o tcptls.o tdd.o term.o threadstorage.o
translate.o udptl.o ulaw.o utils.o version.o editline/libedit.a db1-ast/libdb1.a
minimime/libmmime.a buildinfo.o -lssl -lcrypto -lc  -ldl -lcap  -lpthread
-ltinfo  -lm -lresolv 
make[1]: *** [asterisk] Error 1

Comment 2 David Woodhouse 2008-02-26 20:07:05 EST
And it did actually create main/asterisk too.
Comment 3 David Woodhouse 2008-02-26 20:23:00 EST
Curiouser and curiouser. With CC set to a shell script which displays the
arguments to GCC, saves the environment and also prints the result, I see that
GCC wasn't actually returning failure. And still make reports failure:

/builddir/build/BUILD/asterisk-1.6.0-beta4/fff  -o asterisk -Wl,--export-dynamic
  abstract_jb.o acl.o adsistub.o aescrypt.o aeskey.o aestab.o alaw.o app.o
ast_expr2.o ast_expr2f.o asterisk.o astmm.o astobj2.o audiohook.o autoservice.o
callerid.o cdr.o channel.o chanvars.o cli.o config.o cryptostub.o db.o
devicestate.o dial.o dns.o dnsmgr.o dsp.o enum.o event.o features.o file.o
fixedjitterbuf.o frame.o fskmodem.o global_datastores.o hashtab.o http.o image.o
indications.o io.o jitterbuf.o libresample/src/filterkit.o
libresample/src/resample.o libresample/src/resamplesubs.o loader.o logger.o
manager.o md5.o netsock.o pbx.o plc.o privacy.o rtp.o say.o sched.o sha1.o
slinfactory.o srv.o stdtime/localtime.o strcompat.o tcptls.o tdd.o term.o
threadstorage.o translate.o udptl.o ulaw.o utils.o version.o editline/libedit.a
db1-ast/libdb1.a minimime/libmmime.a buildinfo.o -lssl -lcrypto -lc  -ldl -lcap
 -lpthread -ltinfo  -lm -lresolv 
GCC returned 0
make[1]: *** [asterisk] Error 1
mock-chroot> cat fff
#!/bin/sh

set > /tmp/gcc-env
/usr/bin/gcc "$@"
RET=$?
echo GCC returned $RET
exit $RET
Comment 4 David Woodhouse 2008-02-26 20:23:34 EST
   Finished prerequisites of target file `asterisk'.
  Must remake target `asterisk'.
Putting child 0x100c8050 (asterisk) PID 23812 on the chain.
Live child 0x100c8050 (asterisk) PID 23812 
GCC returned 0
Reaping winning child 0x100c8050 PID 23812 
Live child 0x100c8050 (asterisk) PID 23816 
Reaping winning child 0x100c8050 PID 23816 
/builddir/build/BUILD/asterisk-1.6.0-beta4/fff  -o asterisk -Wl,--export-dynamic
  abstract_jb.o acl.o adsistub.o aescrypt.o aeskey.o aestab.o alaw.o app.o
ast_expr2.o ast_expr2f.o asterisk.o astmm.o astobj2.o audiohook.o autoservice.o
callerid.o cdr.o channel.o chanvars.o cli.o config.o cryptostub.o db.o
devicestate.o dial.o dns.o dnsmgr.o dsp.o enum.o event.o features.o file.o
fixedjitterbuf.o frame.o fskmodem.o global_datastores.o hashtab.o http.o image.o
indications.o io.o jitterbuf.o libresample/src/filterkit.o
libresample/src/resample.o libresample/src/resamplesubs.o loader.o logger.o
manager.o md5.o netsock.o pbx.o plc.o privacy.o rtp.o say.o sched.o sha1.o
slinfactory.o srv.o stdtime/localtime.o strcompat.o tcptls.o tdd.o term.o
threadstorage.o translate.o udptl.o ulaw.o utils.o version.o editline/libedit.a
db1-ast/libdb1.a minimime/libmmime.a buildinfo.o -lssl -lcrypto -lc  -ldl -lcap
 -lpthread -ltinfo  -lm -lresolv 
Live child 0x100c8050 (asterisk) PID 23817 
GCC returned 0
Reaping winning child 0x100c8050 PID 23817 
Live child 0x100c8050 (asterisk) PID 23868 
Reaping losing child 0x100c8050 PID 23868 
make[1]: *** [asterisk] Error 1
Removing child 0x100c8050 PID 23868 from chain.
make[1]: Leaving directory `/builddir/build/BUILD/asterisk-1.6.0-beta4/main'
Reaping losing child 0x100b8d70 PID 23302 
make: *** [main] Error 2
Removing child 0x100b8d70 PID 23302 from chain.
Comment 5 David Woodhouse 2008-02-26 22:33:42 EST
Oh, it's the strip script which is failing. Silently. When make was silent about
running it too. 

http://david.woodhou.se/asterisk-1.6.0-beta4-funcdesc.patch
Comment 6 David Woodhouse 2008-02-26 22:47:00 EST
I have a disclaimer on file with Digium, not that a patch this simple really
needs it.
Comment 7 Jeffrey C. Ollie 2008-02-26 23:56:17 EST
Ah, the good old disclaimers...  Anyway, I've filed bug 12081 upstream with
Digium.  I'll close out this report since I've gotten a successful PPC64 build now.

http://bugs.digium.com/view.php?id=12081

Thanks for taking a look at this so quickly!

Note You need to log in before you can comment on or make changes to this bug.