Bug 435056 - needs better docs
needs better docs
Status: CLOSED DUPLICATE of bug 439245
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 21:01 EST by Bill Nottingham
Modified: 2014-06-18 04:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 20:30:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-02-26 21:01:29 EST
Description of problem:

Well, so does everything, I suppose. However, the sum total of docs on event
writing that I can find are:

http://upstart.ubuntu.com/getting-started.html
http://upstart.ubuntu.com/wiki/Stanzas

neither of which is remotely close to comprehensive. There's a lot of other
stuff on the wiki, but as it's all in-development specs, it's not particularly
useful.

Version-Release number of selected component (if applicable):

upstart-0.3.9-5.fc9.x86_64
Comment 1 Casey Dahlin 2008-02-26 21:34:09 EST
What's the delivery mechanism we want to use? Just drop stuff in the docs folder?

The Manpages do a pretty good job of describing the commands and the general
workings, its just the job definitions where information is sparse (even I'm not
certain what all is available). We could add a man event.d page that explained
these.
Comment 2 Bill Nottingham 2008-02-26 21:51:11 EST
The event definition stuff is what I'm missing; there seems to be a lack of
anything that describes how to write non-trivial events. For example, our prefdm
script has:

stop on runlevel [!5]

but I'm unable to find anything that describes that syntax, or what other
globbing/operators may be available, or variable substitutions, etc.
Comment 3 Casey Dahlin 2008-02-26 21:56:42 EST
That only got written because Scott wrote it :)

We'll need him in on this methinks.
Comment 4 Scott James Remnant 2008-02-27 05:12:42 EST
Part of the reason that there's not much documentation on the job definition
format is that it's been subject to change, and I didn't want people relying on
anything more than the basic features documented on getting-started (even those
changed with 0.3! :p)

Documentation will be coming though, as soon somebody (me probably :-/) sits
down and writes it -- code comes first tho :p

For the record, the globbing is done with fnmatch() so follows glob(7) rules
Comment 5 Bill Nottingham 2008-04-04 20:30:43 EDT

*** This bug has been marked as a duplicate of 439245 ***

Note You need to log in before you can comment on or make changes to this bug.