This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 439245 - man page doesn't document how to configure mingetty/c-a-d handling, etc
man page doesn't document how to configure mingetty/c-a-d handling, etc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
: 435056 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-27 13:38 EDT by Daniel Berrange
Modified: 2014-06-18 04:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 20:49:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
katzj: fedora_requires_release_note?


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2008-03-27 13:38:42 EDT
Description of problem:
The /etc/inittab file is no longer used by upstart. There is no documentation in
the 'init' manpage shipped with upstart which explains what configuration
file(s) replace it.

Specifically it needs to document at least

 - where/how to switch text vs graphical boot (runlevel 3 vs 5 equivalent)
 - where/how to configure mingetty spawning for text console
 - where/how to configure agetty for serial consoles
 - where/how to override the default C-A-D handling


Version-Release number of selected component (if applicable):
upstart-0.3.9-9.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. man init
2.
3.
  
Actual results:
No docs on how to configure the 4 points listed above

Expected results:
Documentation on configuration.

Additional info:
Comment 1 Bill Nottingham 2008-03-27 13:54:25 EDT
The problem with doing this in upstart is that everything in upstart is a
generic event; ergo, 'how to configure mingetty' is all related to how the
distribution in question sets up their upstart events; there would be no
'upstart' way to do it.
Comment 2 Daniel Berrange 2008-03-27 14:11:54 EDT
The current man page doesn't even document what events are available, or how to
discover them, or the format of files you stuff into /etc/event.d. So there no
way for users to even make an intelligent guess at the necessary configuration
steps. Some manpage needs to document the available events for the way Fedora
deploys upstart, preferrably with examples to illustrate configs equivalent to
old style inittab settings. Either 'init' man page itself, or perhaps it just
has a reference to a separate Fedora specific man page describing events / examples.
Comment 3 Bill Nottingham 2008-04-04 11:28:02 EDT
Documented inittab added in initscripts-8.68-1.
Comment 4 Bill Nottingham 2008-04-04 20:30:45 EDT
*** Bug 435056 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2008-04-04 20:49:11 EDT
Added an 'events' manpage in -15.

Note You need to log in before you can comment on or make changes to this bug.