Bug 435133 - kde3 apps need khelpcenter service/app
kde3 apps need khelpcenter service/app
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdebase3 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-02-27 11:15 EST by Rex Dieter
Modified: 2008-04-17 12:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 10:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2008-02-27 11:15:51 EST
OK, here's an ugly truth I discovered. :)

kde3 apps need both /usr/share/services/khelpcenter.desktop and
/usr/bin/khelpcenter to be able to display their handbook/documentation (Help ->
<foo> Handbook)

Turns out we had recently omitted khelpcenter from kdebase3 and lost
/usr/share/services/khelpcenter.desktop.  I just reverted that, for now.

In the meantime, many kde3 apps have no direct dependency on khelpcenter.  Point
is, what should we do:
1.  Allow apps to be installed without khelpcenter infrastructure (status quo).
2.  Add a khelpcenter dependency somewhere global, say, kdelibs (or equivalent),
so khelpcenter is always available.
3.  Add a khelpcenter dependency to all kde3 apps.

Either way, a tangential issue is to consider splitting khelpcenter out of
kdebase(3) (kdebase(3)-runtime?), to allow apps finer-grained access to this
(even on F-7/F-8) without pulling in *all* of kdebase.  See amarok bug #426803 ,
for example.
Comment 1 Sebastian Vahl 2008-03-04 03:26:52 EST
(In reply to comment #0)
> Either way, a tangential issue is to consider splitting khelpcenter out of
> kdebase(3) (kdebase(3)-runtime?), to allow apps finer-grained access to this
> (even on F-7/F-8) without pulling in *all* of kdebase.

+1 

This would also free some space on the live images (bug 435873).

Comment 2 Rex Dieter 2008-04-17 10:48:19 EDT
Discussed on irc with Than, decided to go with plan 1, status quo (for now).
Comment 3 Kevin Kofler 2008-04-17 12:47:29 EDT
For those who read this and haven't followed all our discussions on this issue: 
the original problem was that the applications needed both kdebase3 and 
kdebase-runtime. This was fixed: only a single .desktop file from kdebase3 was 
needed, that is now provided by kdebase-runtime. So now only kdebase-runtime is 
required for help. What's not there is explicit Requires: kdebase-runtime on 
KDE 3 apps using khelpcenter, and I'm not convinced it's a good idea anyway.

Note You need to log in before you can comment on or make changes to this bug.