Bug 435148 - Pidgin crashes with PulseAudio unavailable.
Pidgin crashes with PulseAudio unavailable.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-plugins (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Eric Moret
Fedora Extras Quality Assurance
:
: 436450 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 11:52 EST by Ray Van Dolson
Modified: 2008-03-26 12:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-08 10:03:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pidgin debug log (36.73 KB, text/plain)
2008-02-27 11:52 EST, Ray Van Dolson
no flags Details
Backtrace from pidgin crash. (7.86 KB, text/plain)
2008-02-27 14:54 EST, Ray Van Dolson
no flags Details

  None (edit)
Description Ray Van Dolson 2008-02-27 11:52:46 EST
pidgin-2.3.1-1.fc8

I have a Fedora 8 machine that was upgraded from Fedora 7.  As a result,
PulseAudio is not working and I haven't had a chance to figure out why.  By
default it appears that Pidgin tries to use PulseAudio.  As a result, when I
attempt to do anything that results in a sound, pidgin crashes.

If I disable all sounds completely, pidgin works fine.

Will attach debug log.
Comment 1 Ray Van Dolson 2008-02-27 11:52:46 EST
Created attachment 296088 [details]
pidgin debug log
Comment 2 Warren Togami 2008-02-27 12:09:47 EST
Is alsa-plugins-pulseaudio installed?  Does it work if you remove it?
Comment 3 Stu Tomlinson 2008-02-27 12:12:46 EST
Please install pidgin-debuginfo and get a backtrace as described on
http://fedoraproject.org/wiki/StackTraces
Comment 4 Ray Van Dolson 2008-02-27 13:53:45 EST
(In reply to comment #2)
> Is alsa-plugins-pulseaudio installed?  Does it work if you remove it?
> 

Yes, alsa-plugins-pulseaudio was installed.  The problem does seem to go away
when I remove it.

I've reinstalled it now however and will get you a backtrace shortly.
Comment 5 Ray Van Dolson 2008-02-27 14:54:59 EST
Created attachment 296111 [details]
Backtrace from pidgin crash.
Comment 6 Stu Tomlinson 2008-03-03 14:19:48 EST
This appears to be crashing in pulseaudio, re-assigning.
Comment 7 Lubomir Kundrak 2008-03-03 14:36:57 EST
Does the problem persist when you select pulseaudio sink in gnome-sound-properties?

Do other sounds play fine via pulseaudio?
Try paplay /usr/share/gnome-power-manager/gpm-critical-power.wav
Comment 8 Dan O'Brien 2008-03-03 21:51:29 EST
I'm having the same problems mentioned above. I've gone over this with Stu and
the only way I've been able to use Pidgin is by disabling sound notifications in
the app. 

When i try to run gnome-sound-properties I get an alert window that says "Unable
to start the settings manager 'gnome-settings-daemon'.
Without the GNOME settings manager running, some preferences may not take
effect. This could indicate a problem with Bonobo, or a non-GNOME (e.g. KDE)
settings manager may already be active and conflicting with the GNOME settings
manager." 

And when I try to play the sound file above I get " paplay
/usr/share/gnome-power-manager/gpm-critical-power.wav
Connection failure: Connection refused"
Comment 9 Stu Tomlinson 2008-03-07 08:21:06 EST
*** Bug 436450 has been marked as a duplicate of this bug. ***
Comment 10 Ray Van Dolson 2008-03-07 14:47:52 EST
(In reply to comment #7)
> Does the problem persist when you select pulseaudio sink in
gnome-sound-properties?
> 
> Do other sounds play fine via pulseaudio?
> Try paplay /usr/share/gnome-power-manager/gpm-critical-power.wav

Actually, PulseAudio is currently not working on my system.  I did the Fedora 7
to Fedora 8 upgrade which resulted in sound going away and I haven't fixed it yet.

My thinking was that pidgin should at least handle this situation a bit more
gracefully.
Comment 11 Stu Tomlinson 2008-03-07 15:03:01 EST
It isn't pidgin that is causing the crash, there's nothing pidgin can do about a
library asserting on a NULL variable.

However, on further investigation it seems my initial diagnosis was wrong and
this might actually be a problem with the alsa-plugins pulse plugin (or maybe a
gstreamer problem, but that's further up the stack), as pcm_pulse.c is part of
alsa-plugins. Re-assigning again.
Comment 12 Lubomir Kundrak 2008-03-08 10:03:18 EST
Should be fixed in alsa-plugins-1.0.16-1.fc9. Closing, as other related
alsa-plugins-pulseaudio problems are tracked by other bugs.
Comment 13 Ray Van Dolson 2008-03-08 12:31:15 EST
Thanks.  Will this be fixed for Fedora 8 as well?
Comment 14 Lubomir Kundrak 2008-03-08 13:55:45 EST
Ray: is this needed? I'm not for that update, as it has a known workaround and
requires a malfunctioning configuration to be triggered.

However, there are some more issues with the alsa pulse plugin, and I would push
this patch with bugfix update for them in case I find time to fix them.

In case you need the fix for some reason, just pick the pack. It generally just
avoids the problematic assertion as it is bogus.
Comment 15 Tim Waugh 2008-03-26 05:11:03 EDT
I would find the update very useful indeed, as once pidgin gets into this state
it is impossible to start it correctly when operating remotely.
Comment 16 Lubomir Kundrak 2008-03-26 12:13:54 EDT
I am wondering why bodhi did not add a comment here; well; doing it for him:
alsa-plugins-1.0.15-3.fc8.1 was submitted as an stable update for Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.