Bug 436450 - Exits immediately if sound not available
Exits immediately if sound not available
Status: CLOSED DUPLICATE of bug 435148
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-07 04:48 EST by Tim Waugh
Modified: 2008-03-07 08:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-07 08:21:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-03-07 04:48:42 EST
Description of problem:
I use a PulseAudio sound server for audio output, and it works fine.  If the
sound server is not available, pidgin exits like this:

]$ pidgin
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
*** PULSEAUDIO: Unable to create stream.
pidgin: pcm_pulse.c:115: pulse_stop: Assertion `pcm->stream' failed.

My pidgin sound options are:

Sound Method: ALSA
Sound Options:
[Y] Sounds when conversation has focus
Enable sounds: [Only when available]

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Start VNC server session
2.In that session, use padevchooser to select a sound server
3.Start pidgin, configure as above.
4.Close pidgin
5.Stop the sound server
6.Start pidgin
Actual results:
Exits immediately.

Expected results:
Does not exit, just no sound.
Comment 1 Stu Tomlinson 2008-03-07 08:21:05 EST

*** This bug has been marked as a duplicate of 435148 ***

Note You need to log in before you can comment on or make changes to this bug.