Bug 435164 - qemu-dm redirects all stderr to /var/log/xen/qemu-dm-DOMID.log preventing libvirt seeing logs via Xenner
Summary: qemu-dm redirects all stderr to /var/log/xen/qemu-dm-DOMID.log preventing lib...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 435137
Blocks: LibvirtXenner
TreeView+ depends on / blocked
 
Reported: 2008-02-27 18:30 UTC by Daniel Berrange
Modified: 2008-02-27 20:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 20:50:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Let XenD setup qemu logfiles (3.26 KB, patch)
2008-02-27 20:35 UTC, Daniel Berrange
no flags Details | Diff

Description Daniel Berrange 2008-02-27 18:30:25 UTC
Description of problem:
The Xen qemu-dm process re-opens stderr and directs it to a logfile
/var/log/xen/qemu-dm-DOMID.log.

When libvirtd spawns QEMU guests though it expects to be able to capture
messages on stderr, and send them to its own logfile
/var/log/libvirt/qemu/{DOMNAME}.log

So, since Xen is capturing stderr already, when you launch qemu-dm via Xenner we
never get any log messages fed back to libvirt's logfile.

Xen's should qemu-dm should simply not capture the stderr. This functionality
should be moved into XenD itself, allowing calls of qemu-dm to deal with logs as
they see fit.

Version-Release number of selected component (if applicable):
xen-3.2.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Berrange 2008-02-27 20:35:06 UTC
Created attachment 296115 [details]
Let XenD setup qemu logfiles

Comment 2 Daniel Berrange 2008-02-27 20:50:59 UTC
Fix built into rawhide xen-3.2.0-9.fc9


Note You need to log in before you can comment on or make changes to this bug.