Bug 435200 - Frysk using java-gnome 2.16.x crashes with a GSlice error on f8
Summary: Frysk using java-gnome 2.16.x crashes with a GSlice error on f8
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgtk-java   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Stepan Kasal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 173278 328531 435201
TreeView+ depends on / blocked
 
Reported: 2008-02-27 21:43 UTC by Andrew Cagney
Modified: 2008-02-28 21:37 UTC (History)
0 users

Fixed In Version: 2.8.7-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 21:37:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 5797 None None None Never
GNOME Bugzilla 516078 None None None Never

Description Andrew Cagney 2008-02-27 21:43:21 UTC
Opened by Sami Wagiaalla (reporter, points: 7)
2008-02-12 18:38 UTC [reply]

Steps to reproduce:
1. Run frysk
2. Wait for a while
3. It crashes with the error:
   ***MEMORY-ERROR***: Frysk[24796]: GSlice: assertion failed:
sinfo->n_allocated > 0


Stack trace:


Other information:
--Please note that this is a bug against the java-gnome 2.16.x bindings not 4.0
bindings.--

Turns out this is caused by freeing of TreeIter objects using g_slice_free when
they were allocated using g_malloc.

I'll be on the lookout for other instances of this...
Patch is following soon

Comment 1 Fedora Update System 2008-02-28 17:04:57 UTC
libgtk-java-2.8.7-6.fc8 has been submitted as an update for Fedora 8

Comment 2 Fedora Update System 2008-02-28 21:37:39 UTC
libgtk-java-2.8.7-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.