Bug 435201 - Frysk using java-gnome 2.16.x crashes with a GSlice error on f8
Frysk using java-gnome 2.16.x crashes with a GSlice error on f8
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libgtk-java (Show other bugs)
5.2
All Linux
low Severity low
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On: 435200
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 16:48 EST by Andrew Cagney
Modified: 2013-04-12 15:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 14:26:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 516078 None None None Never

  None (edit)
Description Andrew Cagney 2008-02-27 16:48:32 EST
+++ This bug was initially created as a clone of Bug #435200 +++

Opened by Sami Wagiaalla (reporter, points: 7)
2008-02-12 18:38 UTC [reply]

Steps to reproduce:
1. Run frysk
2. Wait for a while
3. It crashes with the error:
   ***MEMORY-ERROR***: Frysk[24796]: GSlice: assertion failed:
sinfo->n_allocated > 0


Stack trace:


Other information:
--Please note that this is a bug against the java-gnome 2.16.x bindings not 4.0
bindings.--

Turns out this is caused by freeing of TreeIter objects using g_slice_free when
they were allocated using g_malloc.

I'll be on the lookout for other instances of this...
Patch is following soon
Comment 1 Andrew Cagney 2008-02-27 16:52:49 EST
This patch fixes incorrect freeing of GTK objects (the wrong method was being used).

Risk of not applying upstream patch.

-> High; frysk, and any other gtk java app that uses trees will crash or corrupt
memory shortly after being started

Risk of applying this patch:

-> Very low; the current code is corrupting memory which this fixes.
Comment 2 Stepan Kasal 2008-07-21 08:04:25 EDT
The patch is small and strightforward, see
http://bugzilla.gnome.org/attachment.cgi?id=105075&action=edit

Note You need to log in before you can comment on or make changes to this bug.