Bug 435344 - nm-connection-editor does not start
Summary: nm-connection-editor does not start
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 441037 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-28 19:52 UTC by Ville Skyttä
Modified: 2008-07-09 21:47 UTC (History)
3 users (show)

Fixed In Version: 0.7.0-0.6.9.svn3675.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 21:47:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2008-02-28 19:52:51 UTC
nm-connection-editor does not start:

$ nm-connection-editor
** (nm-connection-editor:3671): WARNING **: Icon lock missing: Icon 'lock' not
present in theme
(nm-connection-editor:3671): Gtk-CRITICAL **: gtk_dialog_run: assertion
`GTK_IS_DIALOG (dialog)' failed
(nm-connection-editor:3671): Gtk-CRITICAL **: gtk_widget_hide: assertion
`GTK_IS_WIDGET (widget)' failed
(nm-connection-editor:3671): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed
(nm-connection-editor:3671): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed
(nm-connection-editor:3671): Gtk-CRITICAL **: gtk_widget_destroy: assertion
`GTK_IS_WIDGET (widget)' failed
(nm-connection-editor:3671): GLib-CRITICAL **: g_hash_table_destroy: assertion
`hash_table != NULL' failed
(nm-connection-editor:3671): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed
$

This is F-8 x86_64, KDE, NetworkManager from updates-testing.  Nothing happens
from the applet's right-click->edit connections either.

NetworkManager-glib-0.7.0-0.6.7.svn3302.fc8.x86_64
NetworkManager-gnome-0.7.0-0.6.7.svn3302.fc8.x86_64
NetworkManager-0.7.0-0.6.7.svn3302.fc8.x86_64
NetworkManager-openvpn-0.7.0-8.svn3302.fc8.x86_64
knetworkmanager-openvpn-0.2-0.7.fc8.x86_64
knetworkmanager-0.2-0.7.fc8.x86_64

Comment 1 Dan Williams 2008-02-29 20:16:22 UTC
Ok; thanks.  lock is only in gnome-icon-theme or Bluecurve, but those probably
an undesirable dep of the applet, so I'll figure something out.

Comment 2 Ville Skyttä 2008-03-01 07:32:33 UTC
I did have gnome-icon-theme installed at the time I reported this; for testing I
also installed bluecurve-icon-theme (and I already had bluecurve-kde-theme
installed) but those don't seem to make any difference.

Comment 3 Dan Williams 2008-03-03 01:23:39 UTC
Huh.  lock.png does exist in gnome-icon theme; can you run
'gtk-update-icon-cache -f /usr/share/icons/gnome' for me and see if that helps?
 Any icon theme RPM that provides icons for GTK apps should be running that in
the %post; sometimes it gets forgotten.  In any case I'll add a dep on
gnome-icon-theme to NetworkManager-gnome.

Comment 4 Ville Skyttä 2008-03-03 21:34:40 UTC
"gtk-update-icon-cache -f /usr/share/icons/gnome" did not have any effect.

But when I manually started /usr/libexec/gnome-settings-daemon (note that I run
KDE - such things aren't normally running), something started to happen.

I still can't do anything useful with nm-connection-editor (Add, Edit buttons
disabled) but maybe that's another bug; at least the window appears now.

Comment 5 Dan Williams 2008-04-08 17:08:25 UTC
*** Bug 441037 has been marked as a duplicate of this bug. ***

Comment 6 Dan Williams 2008-04-08 17:08:46 UTC
What's the output of:

find /usr/share/icons/ -name "lock*"



Comment 7 Gerwin Krist 2008-04-08 17:59:22 UTC
Having /usr/libexec/gnome-settings-daemon running does "fix" indeed the loading
of the program. But as Ville said nothing works there ...

OUTPUT find /usr/share/icons/ -name "lock*":

/usr/share/icons/crystalsvg/48x48/actions/lock.png
/usr/share/icons/crystalsvg/48x48/actions/lockkey.png
/usr/share/icons/crystalsvg/16x16/actions/lock.png
/usr/share/icons/crystalsvg/16x16/actions/lockkey.png
/usr/share/icons/crystalsvg/scalable/actions/lockkey.svgz
/usr/share/icons/crystalsvg/scalable/actions/lock.svgz
/usr/share/icons/crystalsvg/64x64/actions/lockkey.png
/usr/share/icons/crystalsvg/32x32/actions/lock.png
/usr/share/icons/crystalsvg/32x32/actions/lockkey.png
/usr/share/icons/crystalsvg/22x22/actions/lock.png
/usr/share/icons/crystalsvg/22x22/actions/lockkey.png
/usr/share/icons/mono/scalable/places/lock-overlay.svgz
/usr/share/icons/Bluecurve/48x48/actions/lock.png
/usr/share/icons/Bluecurve/16x16/actions/lock.png
/usr/share/icons/Bluecurve/64x64/actions/lock.png
/usr/share/icons/Bluecurve/24x24/actions/lock.png
/usr/share/icons/Bluecurve/32x32/actions/lock.png
/usr/share/icons/Bluecurve/20x20/actions/lock.png
/usr/share/icons/gnome/16x16/actions/lock.png
/usr/share/icons/gnome/scalable/actions/lock.svg
/usr/share/icons/gnome/24x24/actions/lock.png
/usr/share/icons/gnome/32x32/actions/lock.png
/usr/share/icons/gnome/22x22/actions/lock.png
/usr/share/icons/HighContrast-SVG/scalable/actions/lock.svg


Comment 8 Dan Williams 2008-04-08 19:18:43 UTC
Yeah, Add/Edit are disabled until they are fully implemented.  You can delete
user connections though; add/edit are coming quite soon.

Having to start gnome-settings-daemon under KDE is of course suboptimal, I've
committed a fix upstream (applet r657) that will filter back to f8-updates-testing.

Comment 9 Gerwin Krist 2008-04-09 06:16:25 UTC
also to rawhide? I'm having this bug on rawhide :)

Comment 10 Dan Williams 2008-04-09 15:56:54 UTC
Yeah, svn3548 was built into rawhide/koji yesterday; testing appreciated.  You
could probably pull them from Koji.

Comment 11 Gerwin Krist 2008-04-09 16:49:35 UTC
Todays rawhide updates did not fixed it. What is the packagename I will get it
from koji then ...

Comment 12 Dan Williams 2008-04-10 13:41:17 UTC
svn3548 or later:

http://koji.fedoraproject.org/koji/buildinfo?buildID=45779

can you test?

Comment 13 Gerwin Krist 2008-04-10 15:16:28 UTC
thanks, works,  now the edit dialog popups without errors on console ...

Comment 14 Fedora Update System 2008-05-19 15:46:47 UTC
NetworkManager-0.7.0-0.6.8.svn3669.fc8 has been submitted as an update for Fedora 8

Comment 15 Fedora Update System 2008-07-09 21:47:14 UTC
NetworkManager-0.7.0-0.6.9.svn3675.fc8, NetworkManager-openvpn-0.7.0-10.svn3632.fc8, NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.