Bug 435454 - Unreasonable dependencies for ImageMagick
Unreasonable dependencies for ImageMagick
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Norm Murray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 09:25 EST by Tethys
Modified: 2009-11-08 20:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 02:11:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2008-02-29 09:25:33 EST
Description of problem:
Installing ImageMagick tries to pull in far too many unnecesasry packages.
I want to manipulate images. I don't need a zeroconf daemon, a file
alteration monitor, a CSS parsing library or a keyring daemon!

Version-Release number of selected component (if applicable):
6.3.2.9-3.fc7

How reproducible:
Every time.

Steps to Reproduce:
1. yum install ImageMagick
2.
3.

Additional info:
asia:~# yum install ImageMagick
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
fedora                    100% |=========================| 2.1 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 2.4 MB    00:02     
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.i386 0:6.3.2.9-3.fc7 set to be updated
--> Processing Dependency: libwmflite-0.2.so.7 for package: ImageMagick
--> Processing Dependency: librsvg-2.so.2 for package: ImageMagick
--> Processing Dependency: liblcms.so.1 for package: ImageMagick
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package librsvg2.i386 0:2.16.1-1.fc7 set to be updated
---> Package libwmf.i386 0:0.2.8.4-14.fc7 set to be updated
---> Package lcms.i386 0:1.16-3 set to be updated
--> Processing Dependency: libcroco-0.6.so.3 for package: librsvg2
--> Processing Dependency: libgnomevfs-2.so.0 for package: librsvg2
--> Processing Dependency: gnome-vfs2 >= 1.9.16 for package: librsvg2
--> Processing Dependency: libgsf-1.so.114 for package: librsvg2
--> Processing Dependency: libgsf >= 1.6.0 for package: librsvg2
--> Processing Dependency: libcroco >= 0.6.1 for package: librsvg2
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package gnome-vfs2.i386 0:2.18.1-4.fc7 set to be updated
---> Package libcroco.i386 0:0.6.1-2.1 set to be updated
---> Package libgsf.i386 0:1.14.3-4.fc7 set to be updated
--> Processing Dependency: libfam.so.0 for package: gnome-vfs2
--> Processing Dependency: libavahi-glib.so.1 for package: gnome-vfs2
--> Processing Dependency: shared-mime-info for package: gnome-vfs2
--> Processing Dependency: gnome-mount >= 0.4 for package: gnome-vfs2
--> Processing Dependency: gnome-mime-data >= 2.0.0-11 for package: gnome-vfs2
--> Processing Dependency: libavahi-common.so.3 for package: gnome-vfs2
--> Processing Dependency: libavahi-client.so.3 for package: gnome-vfs2
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package gnome-mount.i386 0:0.6-2.fc7 set to be updated
---> Package avahi-glib.i386 0:0.6.17-1.fc7 set to be updated
---> Package gamin.i386 0:0.1.8-5.fc7 set to be updated
---> Package shared-mime-info.i386 0:0.20-2.fc7 set to be updated
---> Package gnome-mime-data.noarch 0:2.18.0-2.fc7 set to be updated
---> Package avahi.i386 0:0.6.17-1.fc7 set to be updated
--> Processing Dependency: pkgconfig for package: gnome-mime-data
--> Processing Dependency: libdaemon.so.0 for package: avahi
--> Processing Dependency: libdaemon for package: avahi
--> Processing Dependency: libgnome-keyring.so.0 for package: gnome-mount
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package pkgconfig.i386 1:0.21-6.fc7 set to be updated
---> Package gnome-keyring.i386 0:0.8-1.fc7 set to be updated
---> Package libdaemon.i386 0:0.11-2.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 ImageMagick             i386       6.3.2.9-3.fc7    fedora            3.5 M
Installing for dependencies:
 avahi                   i386       0.6.17-1.fc7     fedora            252 k
 avahi-glib              i386       0.6.17-1.fc7     fedora             14 k
 gamin                   i386       0.1.8-5.fc7      fedora            120 k
 gnome-keyring           i386       0.8-1.fc7        fedora            179 k
 gnome-mime-data         noarch     2.18.0-2.fc7     fedora            724 k
 gnome-mount             i386       0.6-2.fc7        fedora            112 k
 gnome-vfs2              i386       2.18.1-4.fc7     fedora            1.3 M
 lcms                    i386       1.16-3           fedora            172 k
 libcroco                i386       0.6.1-2.1        fedora            127 k
 libdaemon               i386       0.11-2.fc7       updates            25 k
 libgsf                  i386       1.14.3-4.fc7     fedora            110 k
 librsvg2                i386       2.16.1-1.fc7     fedora            179 k
 libwmf                  i386       0.2.8.4-14.fc7   fedora            818 k
 pkgconfig               i386       1:0.21-6.fc7     updates            66 k
 shared-mime-info        i386       0.20-2.fc7       fedora            150 k

Transaction Summary
=============================================================================
Install     16 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)
Comment 1 Dmitry S. Makovey 2008-03-05 18:47:07 EST
same applies to EL5 - it's a server and not a desktop to pull in half-of-gnome.
please, can it not be broken into manageable parts?

Installing:
 ImageMagick             i386       6.2.8.0-3.el5.4  rhel-i386-server-5  3.3 M
Installing for dependencies:
 alsa-lib                i386       1.0.14-1.rc4.el5  rhel-i386-server-5  407 k
 audiofile               i386       1:0.2.6-5        rhel-i386-server-5  107 k
 avahi                   i386       0.6.16-1.el5     rhel-i386-server-5  249 k
 avahi-glib              i386       0.6.16-1.el5     rhel-i386-server-5   14 k
 chkfontpath             i386       1.10.1-1.1       rhel-i386-server-5   15 k
 esound                  i386       1:0.2.36-3       rhel-i386-server-5  130 k
 gamin                   i386       0.1.7-8.el5      rhel-i386-server-5  118 k
 gd                      i386       2.0.33-9.4.el5_1.1  rhel-i386-server-5  157 k
 ghostscript             i386       8.15.2-9.1.el5_1.1  rhel-i386-server-5  5.9 M
 ghostscript-fonts       noarch     5.50-13.1.1      rhel-i386-server-5  801 k
 gnome-keyring           i386       0.6.0-1.fc6      rhel-i386-server-5  170 k
 gnome-mime-data         i386       2.4.2-3.1        rhel-i386-server-5  691 k
 gnome-mount             i386       0.5-3.el5        rhel-i386-server-5   70 k
 gnome-vfs2              i386       2.16.2-4.el5     rhel-i386-server-5  1.3 M
 lcms                    i386       1.15-1.2.2       rhel-i386-server-5  168 k
 libFS                   i386       1.0.0-3.1        rhel-i386-server-5   30 k
 libXfont                i386       1.2.2-1.0.3.el5_1  rhel-i386-server-5  241 k
 libXpm                  i386       3.5.5-3          rhel-i386-server-5   45 k
 libart_lgpl             i386       2.3.17-4         rhel-i386-server-5   76 k
 libbonobo               i386       2.16.0-1.fc6     rhel-i386-server-5  501 k
 libbonoboui             i386       2.16.0-1.fc6     rhel-i386-server-5  390 k
 libcroco                i386       0.6.1-2.1        rhel-i386-server-5  127 k
 libdaemon               i386       0.10-5.el5       rhel-i386-server-5   24 k
 libfontenc              i386       1.0.2-2.2.el5    rhel-i386-server-5   19 k
 libglade2               i386       2.6.0-2          rhel-i386-server-5   96 k
 libgnome                i386       2.16.0-6.el5     rhel-i386-server-5  859 k
 libgnomecanvas          i386       2.14.0-4.1       rhel-i386-server-5  222 k
 libgnomeui              i386       2.16.0-5.el5     rhel-i386-server-5  977 k
 libgsf                  i386       1.14.1-6.1       rhel-i386-server-5  116 k
 librsvg2                i386       2.16.1-1.el5     rhel-i386-server-5  179 k
 libwmf                  i386       0.2.8.4-10.1     rhel-i386-server-5  821 k
 pkgconfig               i386       1:0.21-1.fc6     rhel-i386-server-5   58 k
 shared-mime-info        i386       0.19-3.el5       rhel-i386-server-5  148 k
 ttmkfdir                i386       3.0.9-23.el5     rhel-i386-server-5   46 k
 urw-fonts               noarch     2.3-6.1.1        rhel-i386-server-5  4.5 M
 xorg-x11-font-utils     i386       1:7.1-2          rhel-i386-server-5   75 k
 xorg-x11-xfs            i386       1:1.0.2-4        rhel-i386-server-5   68 k
Comment 2 Hans de Goede 2008-04-26 02:11:51 EDT
Quick intro: I'm now a comaintainer of ImageMagick, and thus going through all
the open bugs.

This is caused by
/usr/lib/ImageMagick-6.3.8/modules-Q16/coders/svg.so

Which requires librsvg2. Requiring an svg lib is not strange for an image
manipulation package.

The real problem here is librsvg2 dragging in gnomevfs, presumably through
/usr/bin/rsvg-view

In rawhide / F-9 with the switching from gnomevfs to gvfs the gnomevfs dep is
gone, so I'm closing this with a resolution of rawhide.


Note You need to log in before you can comment on or make changes to this bug.