Bug 435548 - update to latest release
update to latest release
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
http://www.ghostscript.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-01 07:54 EST by acount closed by user
Modified: 2008-03-14 10:47 EDT (History)
0 users

See Also:
Fixed In Version: 8.62-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 09:33:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2008-03-01 07:54:46 EST
Changelog Version 8.62 (2008-02-29)

This version is the next in our line of scheduled semi-annual releases.

There were approximately 55 bugs fixed since version 8.61. Some fixes and
improvements of note were:

COMPILE_INITS=1 was broken in 8.61 and now works as expected.

Fonts are now distributed in the Resource/Font directory and will be included in
the executable if COMPILE_INITS=1

The tiffsep device was fixed for using more than 8 colorants.

Shadings, overprinting and transparency were optimized and are substantially
faster than in 8.61, particularly for large format or high resolution rendering
when using the 'clist' banding mode.

Changes were made to prevent near unbounded growth in memory usage and
corresponding performance problems on a few test cases.

The 'pdfwrite' device was improved to fix some compatibility issues with PDF/A
and to improve some font embedding and other issues.

The 'ht_ccsto.ps' Stochastic Threshold array was completely changed to be more
useful. The values in the threshold array were inverted, so the number of
'light' colors was limited and using it generally caused prints that were too dark.

The 'runpdfbegin', 'dopdfpages' and 'runpdfend' PostScript pseudo-operators that
were inadvertently removed in 8.61 were restored. This also restored the
functionality of toolbin/pdf_info.ps to display PDF creator stats, fonts used
and page sizes.

The halftone tile cache sizes and cache effectiveness were improved to help the
performance when tiling with large cells or threshold arrays.




*Incompatible changes*

Not strictly a compatibility issue, but the default URW (GPL) fonts are now
distributed in the Resource/Font/ path which can increase the number of file
handles open for PostScript that opens all of the resources. Also the size of
the %rom% rom file system within the executable when using COMPILE_INITS=1 is
larger by the amount needed for the fonts.

Also not strictly incompatible, but some alternate fixed-point code was stripped
out, so FPU_TYPE and other FPU related makefile macros are gone or don't cause
any difference in the code generated. Also the 'USE_ASM' macro was removed,
since we expect modern compilers to do sufficient optimization.

Some old (deprecated) "helper" scripts were removed: gsindent, gssubst,
many2pdf.tcl, and pre.

The unused 'cmap' (special color mapping) and 'ropc' devices were removed from
the distribution.

The 'ht_ccsto.ps' Stochastic Threshold array was completely changed to be more
useful. The values in the threshold array were inverted, so the number of
'light' colors was limited and using it generally caused prints that were too
dark. This is an improvement, but incompatible in that anyone using it
previously would see much different grays/ colors.

The SYSTEM_CONSTANTS_ARE_WRITABLE compile time define was removed as was the
"EXTEND_NAMES" makefile macro (still accessible using a compiler flag define). 



-thanks-
Comment 1 acount closed by user 2008-03-14 10:47:28 EDT
*** Bug 435549 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.