Bug 435620 - yum/rpm says: "error: failed to stat /home/tbl/.gvfs: Permission denied"
yum/rpm says: "error: failed to stat /home/tbl/.gvfs: Permission denied"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 440230 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 12:43 EST by Tom London
Modified: 2008-04-02 09:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: rpm-4.4.2.3-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 04:18:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 520403 None None None Never

  None (edit)
Description Tom London 2008-03-02 12:43:51 EST
Description of problem:
Running either rpm or yum, I now get:
error: failed to stat /home/tbl/.gvfs: Permission denied

Doesn't appear to hinder, however.

[tbl@localhost ~]$ ls -ld .gvfs
dr-x------ 2 tbl tbl 0 2008-03-02 09:15 .gvfs
[tbl@localhost ~]$ 

[tbl@localhost ~]$ getfacl .gvfs
# file: .gvfs
# owner: tbl
# group: tbl
user::r-x
group::---
other::---

[tbl@localhost ~]$ 

Version-Release number of selected component (if applicable):
gvfs-0.1.8-1.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-03-02 12:44:50 EST
I should mention that I get this after I "su -", and run rpm or yum as root.
Comment 2 John Ellson 2008-03-03 08:01:29 EST
I have a similar problem, but slightly different behaviour:

ellson@ontap:~> ls -ld .gvfs
ls: cannot access .gvfs: Transport endpoint is not connected
ellson@ontap:~> getfacl .gvfs
getfacl: .gvfs: Transport endpoint is not connected

root@ontap:ellson# ls -ld .gvfs
ls: cannot access .gvfs: Permission denied
root@ontap:ellson# getfacl .gvfs
getfacl: .gvfs: Permission denied
Comment 3 Tomáš Bžatek 2008-03-04 11:47:49 EST
Repro on my rawhide system, some notes:
- repro with gvfs-0.1.10-1.fc9.i386
- caused by gvfs-fuse-daemon (/usr/libexec//gvfs-fuse-daemon /home/tbzatek/.gvfs)
- independent of filesystem the homedir is on


[tbzatek@vmware124 ~]$ ls -ld .gvfs
dr-x------ 2 tbzatek tbzatek 0 2008-03-04 17:39 .gvfs
[tbzatek@vmware124 ~]$ getfacl .gvfs
# file: .gvfs
# owner: tbzatek
# group: tbzatek
user::r-x
group::---
other::---


Another user or root see malformed filesystem record, probably due to the fact
the mounted fuse filesystem is running privately only for the particular user.

[root@vmware124 tbzatek]# ls -al | grep gvfs
ls: cannot access .gvfs: Permission denied
d?????????  ? ?       ?             ?                ? .gvfs

This is causing yum error messages like 
    error: failed to stat /mnt/disk2/home/test/.gvfs: Permission denied
and system-wide utilities:

[root@vmware124 tbzatek]# lsof 
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/tbzatek/.gvfs
      Output information may be incomplete.
Comment 4 Tomáš Bžatek 2008-03-05 09:13:26 EST
Linked to gvfs upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=520403
Comment 5 Matthias Clasen 2008-03-28 01:03:44 EDT
These are really not bugs of gvfs or fuse, but bugs of the tools which can't
handle fuse mounts not being traversable.
Comment 6 Matthias Clasen 2008-03-31 12:14:38 EDT
Moving to the right component.
Comment 7 Panu Matilainen 2008-03-31 12:38:16 EDT
Dupe of bug 432907 but lets track separately as that's for F8.
In any case, fixed upstream already and getting it to Fedora is just a matter of
me getting around to release rpm 4.4.2.3 final...
Comment 8 Panu Matilainen 2008-04-01 04:18:02 EDT
Fixed in rawhide.
Comment 9 John Ellson 2008-04-01 08:37:59 EDT
LOL.  So I see ;)

    * Subject: rawhide special report: 20080401 changes
    * Date: Tue, 1 Apr 2008 12:08:17 +0000 (UTC)

    New package apt
        Advanced front-end for dpkg 

    New package dpkg
        Package maintenance system for Debian 

    Removed package rpm

    Removed package yum

Comment 10 Tomáš Bžatek 2008-04-02 09:30:22 EDT
*** Bug 440230 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.