Bug 435632 - kernel-2.6.25-0.81.rc3.git2.fc9.i686 needs dhcpv6 to install?
kernel-2.6.25-0.81.rc3.git2.fc9.i686 needs dhcpv6 to install?
Status: CLOSED DUPLICATE of bug 435636
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 14:05 EST by Tom London
Modified: 2008-03-02 19:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-02 19:46:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-03-02 14:05:33 EST
Description of problem:
I tried to install 0.81 without dhcpv6 package installed, but got lots of nash
errors messages.

[root@localhost Downloads]# rpm -ivh kernel*
error: failed to stat /home/tbl/.gvfs: Permission denied
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [ 50%]
/sbin/nash: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client
/sbin/nash: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client
/sbin/nash: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client
/sbin/nash: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client
/sbin/nash: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client
/sbin/nash: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client

<<<< SNIP >>>>

/sbin/nash: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client
/sbin/grubby: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client
   2:kernel-devel           ########################################### [100%]
[root@localhost Downloads]# 

After installing dhcpv6 package, rpm is happy:

[root@localhost Downloads]# rpm -ivh kernel*
error: failed to stat /home/tbl/.gvfs: Permission denied
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [ 50%]
   2:kernel-devel           ########################################### [100%]
[root@localhost Downloads]# 


Version-Release number of selected component (if applicable):
kernel-2.6.25-0.81.rc3.git2.fc9.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-03-02 14:17:10 EST
The resulting initrd fails to boot.  Complains with with same error as above: 

/sbin/nash: symbol lookup error: /usr/lib/libdhcp-1.99.so.1: undefined symbol:
dhcpv6_client

and halts.
Comment 2 David Cantrell 2008-03-02 19:46:39 EST

*** This bug has been marked as a duplicate of 435636 ***

Note You need to log in before you can comment on or make changes to this bug.