Bug 435635 - Unhandled exception: UnboundLocalError: local variable 'result' referenced before assignment
Unhandled exception: UnboundLocalError: local variable 'result' referenced be...
Status: CLOSED DUPLICATE of bug 428323
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 14:21 EST by Graham Leggett
Modified: 2008-03-02 21:53 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-02 21:53:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2008-03-02 14:21:10 EST
While running yum update for the first time on a vanilla RHEL5.1 install, the
following uncaught exception is thrown:

(58/96): rsh-0.17-38.el5. 100% |=========================|  44 kB    00:01     
(59/96): openldap-2.3.27- 100% |=========================| 295 kB    00:22     
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 180, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 395, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 690, in downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 447, in getPackage
    cache=cache
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment
Comment 1 James Antill 2008-03-02 21:53:20 EST

*** This bug has been marked as a duplicate of 428323 ***

Note You need to log in before you can comment on or make changes to this bug.