Bug 435652 - keyboard goes berserk with Alt_L KeyPress/KeyRelease events
keyboard goes berserk with Alt_L KeyPress/KeyRelease events
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 20:53 EST by James Ralston
Modified: 2008-03-20 13:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 13:26:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log from session experiencing berserk keyboard (38.18 KB, text/plain)
2008-03-04 23:09 EST, James Ralston
no flags Details
output from "lspci -v" (5.80 KB, text/plain)
2008-03-04 23:10 EST, James Ralston
no flags Details

  None (edit)
Description James Ralston 2008-03-02 20:53:20 EST
Description of problem:

For about a week now, whenever I've been running X, my keyboard will
occasionally become "stuck" in a strange state:

- attempting to bring up the GNOME menu does nothing
- lauching applications does nothing
- attempting to type in windows generates gibberish
- pressing Ctrl-Alt-Backspace to abort the X server does nothing

The only way I have found to "recover" from this state is to hold the power
button down until the system powers off.  :(

The only clue I have as to what might be going on is that the gibberish that
appears when I type in an xterm looks like every key is being prefixed with an
escape character.  E.g., if I type "foo", I
see:

^[^f^[^o^[^o

I can't figure out what triggers this strange state: sometimes it happens a few
minutes after starting up an X server; sometimes I'll go for hours without
triggering it.

Version-Release number of selected component (if applicable):

$ repoquery --envra --pkgnarrow=installed xorg-x11-drv-keyboard 'xorg-x11-server*'
0:xorg-x11-drv-keyboard-1.2.2-4.fc9.i386
0:xorg-x11-server-utils-7.3-3.fc9.i386
0:xorg-x11-server-common-1.4.99.1-0.23.20080222.fc9.i386
0:xorg-x11-server-Xorg-1.4.99.1-0.23.20080222.fc9.i386

How reproducible:

Start up an X session, and simply do random things.  (I think that running
Firefox tends to cause the weird state to occur more frequently, but I'm not sure.)
  
Actual results:

Keyboard becomes useless.

Expected results:

This shouldn't happen.

Additional info:

Due to bug 435649, I can't test against the very latest Rawhide components. 
Once bug 435649 is resolved, I'll try again to reproduce this problem.
Comment 1 Matěj Cepl 2008-03-03 11:13:36 EST
When you will be able, please attach your X server config file
(/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug
report as individual uncompressed file attachments using the bugzilla file
attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 James Ralston 2008-03-03 12:31:46 EST
Ok, bug 435649 was fixed; I'm trying now to reproduce this bug.

(The latest updates might have fixed this bug, so I want to make sure it's
actually still reproducible.)
Comment 3 Matěj Cepl 2008-03-03 18:47:10 EST
Thanks, let us know.
Comment 4 James Ralston 2008-03-04 23:09:36 EST
Created attachment 296842 [details]
/var/log/Xorg.0.log from session experiencing berserk keyboard

Ok, I was able to reproduce this.

If I move my cursor into an xev window while this problem is occurring, xev
shows thousands and thousands of KeyPress/KeyRelease events for Alt_L.	Here's
an excerpt:

KeyPress event, serial 28, synthetic NO, window 0x6a00001,
    root 0x7e, subw 0x0, time 1476693, (137,36), root:(141,55),
    state 0x0, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x6a00001,
    root 0x7e, subw 0x0, time 1476728, (137,36), root:(141,55),
    state 0x8, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

I just updated against the latest Rawhide this afternoon, so unfortunately,
this bug is almost certainly still present.

I'm attaching my Xorg.0.log file.  I'm not using an /etc/X11/xorg.conf file. 
I'll attach "lspci -v" output momentarily.

Versions:

$ repoquery --envra --pkgnarrow=installed xorg-x11-drv-{ati,mouse,keyboard}
'xorg-x11-server*'
0:xorg-x11-drv-mouse-1.2.3-4.fc9.i386
0:xorg-x11-drv-ati-6.8.0-3.fc9.i386
0:xorg-x11-drv-keyboard-1.2.2-4.fc9.i386
0:xorg-x11-server-common-1.4.99.1-0.26.20080227.fc9.i386
0:xorg-x11-server-Xorg-1.4.99.1-0.26.20080227.fc9.i386
0:xorg-x11-server-utils-7.3-3.fc9.i386
Comment 5 James Ralston 2008-03-04 23:10:58 EST
Created attachment 296843 [details]
output from "lspci -v"
Comment 6 James Ralston 2008-03-04 23:13:10 EST
Updating the summary...
Comment 7 James Ralston 2008-03-20 13:26:59 EDT
I haven't seen this problem for a week or so, so I'm fairly certain it was
squashed in one of the recent updates.  I'll reopen if the problem reoccurs, but
for now, I'm closing with RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.