Bug 435692 - Fujitsu-Siemens with S3 Unichrome chip has black screen
Fujitsu-Siemens with S3 Unichrome chip has black screen
Status: CLOSED DUPLICATE of bug 435907
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 06:41 EST by Valent Turkovic
Modified: 2008-03-07 09:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 04:08:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (1.38 KB, application/octet-stream)
2008-03-03 06:42 EST, Valent Turkovic
no flags Details
xorg.conf (1.09 KB, text/plain)
2008-03-03 06:42 EST, Valent Turkovic
no flags Details
Xorg.0.log (41.74 KB, text/plain)
2008-03-03 06:43 EST, Valent Turkovic
no flags Details
Xorg.0.log (51.16 KB, text/plain)
2008-03-06 06:30 EST, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2008-03-03 06:41:25 EST
Description of problem:
I tried booting F8 and F9 Alpha live CD's on Fujitsu-Siemens Amilo Pro V2010
laptop with S3 Unichrome vga card but all I get is a black screen.

I can see that laptops works and it is not frozen because if I "blindly" invoke
terminal and type commands I can see that hard disk is working.

I'll attach the needed logs and lspci listings.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2008-03-03 06:42:12 EST
Created attachment 296581 [details]
lspci
Comment 2 Valent Turkovic 2008-03-03 06:42:34 EST
Created attachment 296582 [details]
xorg.conf
Comment 3 Valent Turkovic 2008-03-03 06:43:05 EST
Created attachment 296583 [details]
Xorg.0.log
Comment 4 Valent Turkovic 2008-03-03 07:02:42 EST
I got feedback from thomasj on IRC saying:
"your crappy videocard (my videocard is crappy as well) needs the unichrome
driver. I dont know were to check if it comes with the livecd"
Comment 5 Valent Turkovic 2008-03-03 07:04:36 EST
I can see that live cd defaults to openchrome driver, is there some way to make
unichrome the default one?
Comment 6 Xavier Bachelot 2008-03-03 17:49:57 EST
(In reply to comment #5)
> I can see that live cd defaults to openchrome driver, is there some way to make
> unichrome the default one?

unichrome is not even packaged, so there's no chance for it to be on the live
cd. I have a spec file for it but I don't want to maintain it in Fedora for a
lot of reasons. If you want, it just ask and I'll dig it from my archives.
Comment 7 Xavier Bachelot 2008-03-03 17:54:39 EST
It seems only the VGA port gets activated and not the laptop's panel.
Could you please try to add Option "ActiveDevice" "LCD" in the device section of
your xorg.conf ? 
Comment 8 Valent Turkovic 2008-03-04 03:30:58 EST
It is a live cd. How do I do that? This is not installed on hdd...
Comment 9 Valent Turkovic 2008-03-04 03:32:04 EST
ups, I can go to VT1 edit the xorg.conf and restart X :) sorry, too early in the
morning... I'll do that.
Comment 10 Xavier Bachelot 2008-03-04 15:16:34 EST
I hit the same bug with another user and we debugged that on irc. Option
"ActiveDevice "LCD" will likely not work, but Option "ForcePanel" should. Please
try both.
Comment 11 Valent Turkovic 2008-03-05 05:55:42 EST
I borrowed that laptop, and I'm waiting it to be returned to me and I'll try it.

If we find that "ForcePanel" works will this be fixed so that Fedora 9 Live CD
boots on these chips?
Comment 12 Xavier Bachelot 2008-03-05 06:04:53 EST
> If we find that "ForcePanel" works will this be fixed so that Fedora 9 Live CD
> boots on these chips?

As soon as upstream will have a fix for this problem, yes, obviously.

Comment 13 Valent Turkovic 2008-03-06 03:46:04 EST
Ok, I have problems troubleshoot this.

I can't bring see VT1, I do CTRL-ALT-F1 and trye root and enter x times and I
see HDD blinks, so I guess I'm logged in but I don't see anything.

I connected external VGA LCD monitor and rebooted, I don't get any image on
external and no image on internal monitor :(

Is there any Fedora page with troubleshooting for live cd? Or documentation for
video issues like this?
Comment 14 Valent Turkovic 2008-03-06 03:49:10 EST
I booted ubuntu 7.10 and I get an error saying:


Ubuntu is running in low-graphics mode

Your screen and graphics card could not be detected correctly. To use higher
resolutions, visual effects or multiple screens, you have to configure the
displays yourself.

[] Allow run in low-graphics mode
Configure     Shut Down    Continue
Comment 15 Valent Turkovic 2008-03-06 04:18:13 EST
comment #13 was for fedora 8 live cd, I'll try now the fedora 9 alpha

and ubuntu doesn't start graphical display no matter if I try to run it in
"low-graphics mode" of if I try to configure the display manually, shows
starting some services but it freezes. But that is offtopic I guess.
Comment 16 Xavier Bachelot 2008-03-06 04:24:49 EST
F8 LiveCD is not shipping with openchrome, it's using the old xorg-x11-drv-via.
Ubuntu is also shipping some outdated openchrome snapshots, iirc. Might not be
true for Hardy tough.
Comment 17 Valent Turkovic 2008-03-06 04:37:57 EST
"ForcePanel" works, but I get a resolution that is much bigger that the display
shows so I actually see only one corner of actual desktop.
Comment 18 Xavier Bachelot 2008-03-06 04:51:12 EST
(In reply to comment #17)
> "ForcePanel" works, but I get a resolution that is much bigger that the display
> shows so I actually see only one corner of actual desktop.

Please attach the matching xorg log.
Comment 19 Valent Turkovic 2008-03-06 04:52:47 EST
Ok, now I got to see the gnome error, and that is it :) Fedora 9A just freezes
after this message;


There was an error starting the GNOME Settings Daemon.

Some things, as themes, sounds, background settings may not work correctly.

GHOME will still try to restart the Settings Daemon next time you log on.

[x] Close


but I can't press close, can't bet back to VT1... nothing... but the CD or HDD
are working all the time, just not responding.
Comment 20 Valent Turkovic 2008-03-06 05:11:33 EST
Option "ActiveDevice" "LCD" doesn't work, I just tested it on F9A, just black
screen. I'll enable again "ForcePanel" and grab the log
Comment 21 Valent Turkovic 2008-03-06 06:30:44 EST
Created attachment 297028 [details]
Xorg.0.log

I booted F9A with "3" as an option to grub menu, then I edited xorg.conf and
added "ForcePanel" option.
I just did "init 5" and then when GDM showed up I did "init 3".

This is the log file.
Comment 22 Xavier Bachelot 2008-03-07 04:08:04 EST
The need for ForcePanel option is fixed in Rawhide, this will appear in the next
LiveCD release.
Please open new bugs for comments #17 (this is likely a VBE problem, removing
the need for VBE is being worked on upstream) and #19 (the later is likely
against gnome, not openchrome)

*** This bug has been marked as a duplicate of 435907 ***
Comment 23 Martin Jürgens 2008-03-07 09:11:53 EST
> but I get a resolution that is much bigger that the display shows so I
actually see only one corner of actual desktop.

I also experienced it (F7 F8 rawhide) and had to hardcode the resolution in
xorg.conf. If you need help debugging it, you can also ping me on IRC, Xavier.

Note You need to log in before you can comment on or make changes to this bug.