Bug 435907 - X does not start using OpenChrome
X does not start using OpenChrome
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
: Reopened
: 435692 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 07:40 EST by Martin Jürgens
Modified: 2008-03-10 20:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.2.901-9.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 20:23:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (44.93 KB, text/plain)
2008-03-04 07:40 EST, Martin Jürgens
no flags Details
xorg.conf (1.49 KB, text/plain)
2008-03-04 07:40 EST, Martin Jürgens
no flags Details
Xorg.0.log with "ActiveDevice" "LCD" (10.40 KB, text/plain)
2008-03-04 11:03 EST, Martin Jürgens
no flags Details
Xorg.0.log with "ForcePanel" (55.30 KB, text/plain)
2008-03-04 11:26 EST, Martin Jürgens
no flags Details
Xorg.0.log with latest package (11.12 KB, text/plain)
2008-03-07 09:27 EST, Martin Jürgens
no flags Details
Xorg.0.log with "ForcePanel" with -9 package (11.12 KB, text/plain)
2008-03-07 09:39 EST, Martin Jürgens
no flags Details
Xorg.0.log with driver version -11 (11.08 KB, text/plain)
2008-03-08 07:49 EST, Martin Jürgens
no flags Details
Xorg.0.log with -12 (11.28 KB, text/plain)
2008-03-08 08:59 EST, Martin Jürgens
no flags Details
Xorg.0.log with -12 2 (41.99 KB, text/plain)
2008-03-09 07:43 EDT, Martin Jürgens
no flags Details
Xorg.1.log from /13 (9.90 KB, text/plain)
2008-03-09 16:17 EDT, Martin Jürgens
no flags Details
Xorg.0.log with -14 (54.58 KB, text/plain)
2008-03-10 09:39 EDT, Martin Jürgens
no flags Details
xorg.conf with -14 (WORKS,YAY!!) (1.63 KB, text/plain)
2008-03-10 09:39 EDT, Martin Jürgens
no flags Details

  None (edit)
Description Martin Jürgens 2008-03-04 07:40:11 EST
Description of problem:
I have a VN800 chipset in my laptop. While Openchrome worked fine for me in
Fedora 8, after having upgraded to rawhide, it does not start

Version-Release number of selected component (if applicable):
Latest Openchrome F9 package

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Black screen

Expected results:
Login manager

Additional info:

I am going to attach Xorg.0.log and xorg.conf
Comment 1 Martin Jürgens 2008-03-04 07:40:11 EST
Created attachment 296731 [details]
Xorg.0.log
Comment 2 Martin Jürgens 2008-03-04 07:40:47 EST
Created attachment 296732 [details]
xorg.conf
Comment 3 Martin Jürgens 2008-03-04 09:51:31 EST
Just found out that it also happens using the vesa driver, but using it, I see
gdm but when I click some buttons in it, Xorg crashes, also.
Comment 4 Xavier Bachelot 2008-03-04 09:57:01 EST
Try to add Option "ActiveDevice" "LCD" in the device section of your xorg.conf.
Comment 5 Martin Jürgens 2008-03-04 10:25:29 EST
When I use the Option, the screen stays black but I do not get any backtrace in
my Xorg.0.log.
Comment 6 Martin Jürgens 2008-03-04 10:28:52 EST
The vesa driver loads, but it crashes when I press any key.
Comment 7 Xavier Bachelot 2008-03-04 10:51:02 EST
(In reply to comment #5)
> When I use the Option, the screen stays black but I do not get any backtrace in
> my Xorg.0.log.

Can you please attach the log with the ActiveDevice option set ?
Also could you please try with Option "ForcePanel" (and attach the log with this
option too) ?
Comment 8 Martin Jürgens 2008-03-04 11:03:21 EST
Created attachment 296755 [details]
Xorg.0.log with "ActiveDevice" "LCD"
Comment 9 Martin Jürgens 2008-03-04 11:08:51 EST
When I use Option "ForcePanel" I get a picture, but when I type something, X
crashes (as with vesa) so probably an Xorg problem (and no openchrome one).
Comment 10 Martin Jürgens 2008-03-04 11:26:18 EST
Created attachment 296758 [details]
Xorg.0.log with "ForcePanel"
Comment 11 Xavier Bachelot 2008-03-07 03:51:56 EST
A fixed package should appear in today's Rawhide push.
xorg-x11-drv-openchrome-0.2.901-9.fc9
Here's the koji build link :
http://koji.fedoraproject.org/koji/buildinfo?buildID=41732

For the record, the evdev crash was fixed by an update to xorg-x11-server
(xorg-x11-server-1.4.99.900-0.27.20080303.fc9)
Comment 12 Xavier Bachelot 2008-03-07 04:08:05 EST
*** Bug 435692 has been marked as a duplicate of this bug. ***
Comment 13 Martin Jürgens 2008-03-07 09:17:58 EST
When I use the updated package without having "ForcePanel" in xorg.conf, the
same issue still appears.
Comment 14 Martin Jürgens 2008-03-07 09:27:21 EST
Created attachment 297186 [details]
Xorg.0.log with latest package
Comment 15 Martin Jürgens 2008-03-07 09:33:24 EST
Error is:

error setting MTRR (base = 0xd1000000, size=0x00009000, type= 1) Invalid
Argument (22)
X: symbol lockup error: /usr/lib/xorg/modules/drivers//openchrome_drv.so:
undefinied symbol: SUBVENDOR_ID
giving up.
xinit: Connection refused [...]

# rpm -qa | grep openchrome
xorg-x11-drv-openchrome-0.2.901-9.fc9.i386
Comment 16 Martin Jürgens 2008-03-07 09:39:12 EST
Created attachment 297188 [details]
Xorg.0.log with "ForcePanel" with -9 package

Even does not start with ForcePanel using the Koji package.
Comment 17 Martin Jürgens 2008-03-07 09:41:40 EST
xorg-x11-drv-openchrome-0.2.901-8.fc9.i386 works using ForcePanel ( I rechecked )
Comment 18 Xavier Bachelot 2008-03-07 10:19:51 EST
Ok, there was a typo in the upstream commit.
New fixed build on it's way :
http://koji.fedoraproject.org/koji/taskinfo?taskID=500907
Comment 19 Martin Jürgens 2008-03-08 07:49:51 EST
Created attachment 297299 [details]
Xorg.0.log with driver version -11
Comment 20 Martin Jürgens 2008-03-08 08:59:32 EST
Created attachment 297302 [details]
Xorg.0.log with -12
Comment 21 Xavier Bachelot 2008-03-08 15:47:16 EST
Hopefully, this is the good one...
http://koji.fedoraproject.org/koji/taskinfo?taskID=503518

Take care the release is still -12.
Comment 22 Martin Jürgens 2008-03-09 07:43:32 EDT
Created attachment 297353 [details]
Xorg.0.log with -12 2

Does not work, but the log says something new which is goood ;)
Comment 23 Xavier Bachelot 2008-03-09 09:01:55 EDT
ok, no need for ForcePanel anymore, but now we're hitting something new, the
VRAM size detection is busted :
(--) CHROME(0): Probed amount of VideoRAM = 1024 kB
You probably can workaround this with Option "VideoRAM" "65536"
Comment 24 Xavier Bachelot 2008-03-09 09:19:39 EDT
What does happen if you change the amount of VRAM in BIOS ? Does the probed VRAM
value move proportionally ? Does it report 512K if you set 32 MB instead of 64 MB ?
Comment 25 Martin Jürgens 2008-03-09 15:28:11 EDT
> Does it report 512K if you set 32 MB instead of 64 MB ?

No it still reports 1024K
Comment 26 Martin Jürgens 2008-03-09 15:36:28 EDT
> No it still reports 1024K

( I changed "Framebuffer Size" in my BIOS, there aren't any other options like that)


Also, using "VideoRAM" "65536" fixes the issue: I have working Xv and do not
have to use ForcePanel.
Comment 27 Xavier Bachelot 2008-03-09 15:50:57 EDT
Ok, thx again for all the tests. Latest Koji build should do the trick. Not as
clean has I'd like it to be, but we need something for F9 Beta.

http://koji.fedoraproject.org/koji/taskinfo?taskID=504580
Comment 28 Martin Jürgens 2008-03-09 16:17:42 EDT
Created attachment 297376 [details]
Xorg.1.log from /13
Comment 29 Xavier Bachelot 2008-03-09 20:44:38 EDT
Martin, I'd be grateful if you can test this one asap tomorrow :
http://koji.fedoraproject.org/koji/taskinfo?taskID=506783

Thanks,
Xavier
Comment 30 Martin Jürgens 2008-03-10 09:38:21 EDT
Works. 

$ rpm -qa | grep openchrome
xorg-x11-drv-openchrome-0.2.901-14.fc9.i386


I am going to attach xorg.conf and Xorg.0.log
Comment 31 Martin Jürgens 2008-03-10 09:39:00 EDT
Created attachment 297429 [details]
Xorg.0.log with -14
Comment 32 Martin Jürgens 2008-03-10 09:39:47 EDT
Created attachment 297430 [details]
xorg.conf with -14 (WORKS,YAY!!)
Comment 33 Xavier Bachelot 2008-03-10 20:23:41 EDT
Thanks you again, Martin :-) The beers are in the fridge...

Note You need to log in before you can comment on or make changes to this bug.