Bug 435699 - smbios-utils does not properly obsolete/provide libsmbios-bin
smbios-utils does not properly obsolete/provide libsmbios-bin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libsmbios (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Michael E Brown
Fedora Extras Quality Assurance
: Reopened
: 435708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 08:38 EST by Jesse Keating
Modified: 2013-01-09 22:17 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 14:45:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-03-03 08:38:57 EST
Summary says it all.  Users will get conflicting files output if they attempt to
update from libsmbios-bin-0.13.13-1.fc9
Comment 1 Michael E Brown 2008-03-03 09:54:50 EST
Fixed in 2.0.1-2, which was just tagged and built in rawhide.
Comment 2 Horst H. von Brand 2008-03-03 11:17:15 EST
*** Bug 435708 has been marked as a duplicate of this bug. ***
Comment 3 Alex Lancaster 2008-03-04 01:44:46 EST
I still get yum errors similar to bug #435708 updating from
libsmbios-bin-0.13.13-1.fc8.i386 on rawhide.  Is there a workaround for this? 
Do you have to manually remove the old package?
Comment 4 Alex Lancaster 2008-03-04 01:47:38 EST
i.e. they mention libsmbios-bin-0.13.13-1.fc8.i386 rather than
libsmbios-bin-0.13.13-1.fc9.i386  as I had originally installed F-8 then yum
updated to rawhide:

Transaction Check Error:
  file /usr/sbin/assetTag from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
  file /usr/sbin/dellBiosUpdate from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
  file /usr/sbin/dellLcdBrightness from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
  file /usr/sbin/dellWirelessCtl from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
  file /usr/sbin/getSystemId from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
  file /usr/sbin/propertyTag from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
  file /usr/sbin/serviceTag from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
  file /usr/sbin/verifySmiPassword from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
  file /usr/sbin/wakeupCtl from install of smbios-utils-2.0.1-1.fc9.i386
conflicts with file from package libsmbios-bin-0.13.13-1.fc8.i386
Comment 5 Andrew Farris 2008-03-04 04:21:03 EST
Alex, workaround (for today's repo, before the fix is there), run:
rpm -e --nodeps libsmbios-bin; yum install smbios-utils libsmbios; yum
--skip-broken update
Comment 6 Michael E Brown 2008-03-04 10:34:43 EST
The other workaround would be to wait until the next rawhide compose, as this
has been built and should be fixed as soon as the new build is pushed to rawhide.
Comment 7 Alex Lancaster 2008-03-04 14:45:26 EST
OK, rawhide build has now been pushed and "yum update" proceeds as expected.

Note You need to log in before you can comment on or make changes to this bug.