Bug 435714 - Missing Requires on pygtk2-libglade
Missing Requires on pygtk2-libglade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dogtail (Show other bugs)
5.2
All Linux
low Severity low
: beta
: ---
Assigned To: Jaroslav Reznik
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 09:53 EST by Alexander Todorov
Modified: 2013-04-12 15:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to a missing pygtk2-libglade runtime dependency, an attempt to run the sniff utility could fail with the following message written to standard error: ImportError: No module named glade This updated package corrects this dependency, so that the sniff utility no longer fails to run.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-02 08:05:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-03-03 09:53:41 EST
Description of problem:
# sniff
Creating logfile at /tmp/dogtail/logs/sniff_20080303-093802_debug ...
Enabling accessibility...
Detecting distribution: Red Hat/Fedora/derived distribution
Warning: AT-SPI's desktop is visible but it has no children. Are you running any
AT-SPI-aware applications?
Traceback (most recent call last):
  File "/usr/bin/sniff", line 16, in ?
    import gtk.glade
ImportError: No module named glade


Version-Release number of selected component (if applicable):
dogtail-0.6.1-2.el5

How reproducible:
100%

Steps to Reproduce:
1. Install a system. My kickstart packages section has:
@development-tools
@development-libs
libxml2-python
ntp
expect
pyOpenSSL
emacs
vim-enhanced

2. dogtail is installed in 1)
3. Install gedit to work around bug #435712
4. Install and start VNC server
5. Run sniff on the exported vnc display
  
Actual results:
Python import error. Application crash.

Expected results:
Application runs.

Additional info:
There are 3 separate bugs that go in the order:
bug #435712, this bug, bug #435702
Comment 1 Alexander Todorov 2008-03-03 09:54:47 EST
After pygtk2-libglade is installed (which is supposed to be a dependency for
dogtail) we hit bug #435702
Comment 4 RHEL Product and Program Management 2008-07-21 19:05:35 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 13 Jaromir Hradilek 2011-02-07 05:22:35 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to a missing pygtk2-libglade runtime dependency, an attempt to run the sniff utility could fail with the following message written to standard error:

  ImportError: No module named glade

This updated package corrects this dependency, so that the sniff utility no longer fails to run.
Comment 15 errata-xmlrpc 2011-03-02 08:05:14 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0315.html

Note You need to log in before you can comment on or make changes to this bug.