Bug 435702 - GError: Couldn't recognize the image file format for file ... when running sniff
GError: Couldn't recognize the image file format for file ... when running sniff
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dogtail (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Jaroslav Reznik
desktop-bugs@redhat.com
:
Depends On:
Blocks: RHEL5u2_relnotes RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-03-03 08:55 EST by Alexander Todorov
Modified: 2013-04-12 15:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
(all architectures) Attempting to run sniff may result in an error. This is because some required packages are not installed with dogtail. To prevent this from occurring, install the following packages manually: * librsvg2 * ghostscript-fonts * pygtk2-libglade
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 11:23:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-03-03 08:55:07 EST
Description of problem:
when trying to run the sniff utility I get the following error:
-------------------------------------------------------------------------------
# sniff
Creating logfile at /tmp/dogtail/logs/sniff_20080303-085240_debug ...
Detecting distribution: Red Hat/Fedora/derived distribution
Warning: AT-SPI's desktop is visible but it has no children. Are you running any
AT-SPI-aware applications?
/usr/bin/sniff:26: GtkWarning: Unable to locate theme engine in module_path:
"clearlooks",
  x = gtk.glade.XML(exec_root + '/share/dogtail/glade/sniff.glade')
Traceback (most recent call last):
  File "/usr/bin/sniff", line 33, in ?
   
sniff.set_icon_from_file('/usr/share/icons/hicolor/scalable/apps/dogtail-head.svg')
GError: Couldn't recognize the image file format for file
'/usr/share/icons/hicolor/scalable/apps/dogtail-head.svg'
-------------------------------------------------------------------------------

Version-Release number of selected component (if applicable):
dogtail-0.6.1-2.el5

How reproducible:
100%

Steps to Reproduce:
1. install dogtail
2. enable accessibility
3. run sniff (in my case on exported VNC display)
  
Actual results:
error. application doesn't run

Expected results:
application runs

Additional info:
Comment 2 Alexander Todorov 2008-03-03 09:56:39 EST
Additional info:
There are 3 separate bugs that go in the order:
bug #435712, bug #435714, this bug.

Also not working for RHEL5.2-Server-20080225.2
Comment 3 Zack Cerza 2008-03-03 10:54:35 EST
I'm not sure what Requires I might be missing here... do you have librsvg installed?
Comment 4 Alexander Todorov 2008-03-03 11:12:13 EST
Nope, it's not installed.
Comment 5 Zack Cerza 2008-03-03 11:20:28 EST
Oops, I meant librsvg2. Probably doesn't matter anyway, as the only package on
my system that requires it is gdm.
Comment 6 Alexander Todorov 2008-03-03 11:25:26 EST
look at the list of installed packages. none of librsvg{2} is installed.
Is that also missing requirement?
Comment 7 Zack Cerza 2008-03-03 11:41:38 EST
It was just a wild guess.
Comment 8 James Laska 2008-03-28 09:38:29 EDT
Is the root of this problem a missing %Requires?  If so, we can document this
and move on to 5.3 for now.  
Comment 9 Zack Cerza 2008-03-28 11:14:41 EDT
I think that's the root of the problem, James, but I'm not sure if it should be
added to dogtail or pygtk2 (or even somewhere else). See the pygtk FAQ:

http://faq.pygtk.org/index.py?req=show&file=faq08.010.htp

"... PyGTK supports svg icons very well via GdkPixbuf ..." - no mention of
dependencies necessary.
Comment 12 Don Domingo 2008-04-08 19:41:46 EDT
this bug has been tagged for inclusion in the RHEl5.2 release notes. please add
the necessary content for it. thanks!
Comment 13 Alexander Todorov 2008-04-09 05:22:00 EDT
Zack,
I don't have a workaround for that yet. I'll try to test it today and get it
working. So far I have no idea what should be in the release notes except that
there is an error. The deadline for rel notes is 15th April.
Comment 14 Alexander Todorov 2008-04-09 07:24:31 EDT
installing librsvg2 worked around the problem. I was able to start sniff.

<rel-note-text>
When running the sniff utility from the dogtail package you may get the
following error:

GError: Couldn't recognize the image file format for file
'/usr/share/icons/hicolor/scalable/apps/dogtail-head.svg'

To work around this make sure that librsvg2 package is installed.
</rel-note-text>
Comment 15 Alexander Todorov 2008-04-09 07:28:01 EDT
Zack,
I have two other questions:

1) Should we rel-note the other 2 bugs cited in comment #2 ?

2) After installing librsvg2 I'm able to start sniff but now get:
Traceback (most recent call last):
  File "/usr/bin/sniff", line 361, in getCellPixbufForNode
    pixbuf = getPixbufForNode(node)
  File "/usr/bin/sniff", line 347, in getPixbufForNode
    return theme.load_icon("gnome-fs-desktop", 24, gtk.ICON_LOOKUP_USE_BUILTIN)
GError: Icon 'gnome-fs-desktop' not present in theme

These traceback is printed on the console many times but it didn't crash the
application. Do you want me to file another bug for it?

Thanks.
Comment 16 Zack Cerza 2008-04-09 12:18:30 EDT
Hmm, okay.

1) Yes, but it may make sense to add one relnote covering all three bugs:
<rel-note-text>
The dogtail package is missing Requires which may prevent the sniff utility from
starting properly. To work around this make sure that the following packages are
installed: 

librsvg2 ghostscript-fonts pygtk2-libglade
</rel-note-text>

I've tried removing every package that you installed to get past bug #435712 and
sniff still starts for me, so I'm pretty confused.

2) Yes please, file another bug.

Many thanks, Alexander.
Comment 17 Alexander Todorov 2008-04-09 12:25:10 EDT
(In reply to comment #16)

> I've tried removing every package that you installed to get past bug #435712 and
> sniff still starts for me, so I'm pretty confused.

Let's move this one to the other bug but here's what I think:
Installing the packages creates a proper fonts directories which are not removed
(I suppose) when the packages are removed. When starting sniff all these
directories are checked for existence (also a wild guess) and since they are
present the application starts.
Comment 18 Don Domingo 2008-04-10 19:15:34 EDT
thanks Zack, Alexander. Revising release note as follows (for RHEL5.2 "Known
Issues"):

<quote>
Attempting to run sniff may result in an error. This is because some required
packages are not installed with dogtail.

To prevent this from occurring, install the following packages manually:

    * librsvg2
    * ghostscript-fonts
    * pygtk2-libglade
</quote>

please advise before April 15 if any further revisions are required. thanks!
Comment 19 RHEL Product and Program Management 2008-07-21 19:05:43 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 20 Ryan Lerch 2008-08-10 21:12:15 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes. 

This Release Note is currently located in the Known Issues section.
Comment 21 Ryan Lerch 2008-08-10 21:12:15 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.
Comment 27 Andre Lammel 2010-04-09 14:33:37 EDT
I ran into the same problem and had the following warning on re-installing librsvg2 via yum:

g_module_open() failed for /usr/lib64/gtk-2.0/2.10.0/loaders/svg_loader.so: /usr/lib64/libgsf-1.so.114: undefined symbol: BZ2_bzCompressInit

It seems to be that the bzip2 library on at least my system does not match that in the fedora build system. Perhaps a rebuild/relink against the right version of the bzip2 library would be enough to solve the problem. But this is only a guess :-)

Regards and thanks!

Note You need to log in before you can comment on or make changes to this bug.