Bug 435763 - Keyboard doesn't respond properly in virt-manager
Keyboard doesn't respond properly in virt-manager
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk-vnc (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Martin Jenner
: Regression
: 437159 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 13:51 EST by Evan McNabb
Modified: 2008-05-21 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2008-0370
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Track based on scancode instead of keycode (2.19 KB, patch)
2008-03-12 15:35 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Evan McNabb 2008-03-03 13:51:52 EST
Description of problem:
In virt-manager, the keyboard repeats some characters when pressed once and
other times it doesn't respond at all to keyboard input for a second or two. I'm
not 100% sure if this is a general Xen issue (e.g. interrupts problem) or a
problem in virt-manager.

Version-Release number of selected component (if applicable):

RHEL5.2 beta (x86_64 paravirt) on a RHEL5.2 beta host (x86_64)
Kernel: 2.6.18-83.el5xen
virtmanager: 0.5.3-2.el5
libvirt: 0.3.3-5.el5

How reproducible:


Steps to Reproduce:
1. Configure using versions above
2. Start paravirt host in virt-manager
3. Type in gnome-terminal
  
Actual results:
A single key press sometimes generates multiple characters or doesn't respond at
all. Occasionally it keeps printing the same character to the screen repeatedly.
Keyboard input also lags behind what is actually typed.

Expected results:
Keyboard should work as in normal RHEL installation.

Additional info:
Comment 1 RHEL Product and Program Management 2008-03-03 16:27:18 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 RHEL Product and Program Management 2008-03-11 15:35:45 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 3 Daniel Berrange 2008-03-12 14:56:19 EDT
The console is actually provided by gtk-vnc, so changing the component
Comment 4 Daniel Berrange 2008-03-12 14:56:32 EDT
*** Bug 437159 has been marked as a duplicate of this bug. ***
Comment 5 Bill Burns 2008-03-12 15:05:12 EDT
Set dev ack for Dan.
Comment 6 Bill Burns 2008-03-12 15:26:11 EDT
Fixing flags.
Comment 7 Daniel Berrange 2008-03-12 15:35:14 EDT
Created attachment 297833 [details]
Track based on scancode instead of keycode
Comment 10 Daniel Berrange 2008-03-19 12:07:06 EDT
Fix built into gtk-vnc-0.3.2-2.el5
Comment 13 errata-xmlrpc 2008-05-21 11:37:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0370.html

Note You need to log in before you can comment on or make changes to this bug.