This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 435768 - Unable to select groups to install
Unable to select groups to install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: MoveUpstream
: 450021 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 14:13 EST by Jeremy Katz
Modified: 2008-10-29 00:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 09:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2008-03-03 14:13:37 EST
Groups in PackageKit are just used as categorization, not as any sort of
indicator of "this set of software is installed".  This makes adding something
new significantly more difficult (and removing even worse).
Comment 1 Richard Hughes 2008-03-03 16:17:14 EST
What's the use case? For installed, we do this as a filter, not as a group.
Comment 2 Jeremy Katz 2008-03-03 22:35:48 EST
The use case is knowing "do I have support for authoring and publishing
installed".  Or "I want to remove KDE".  
Comment 3 Richard Hughes 2008-03-04 06:29:41 EST
Okay, both valid use cases. For this I think we need more API (urgh) to do
things like:

InstallGroup(s=group)
RemoveGroup(s=group)
GetGroups()
Group(s=group, b=installed)

Would this do what we need?
Comment 4 Robin Norwood 2008-03-04 09:46:26 EST
That plus a way to tell which packages are 'recommended/required' for a group,
and which are associated with a group, but optional.

ie:

I click 'Install GNOME', and I get a certain subset of packages.  Some of these
are Required for gnome, and some are in the gnome group, but don't have to be
installed to get GNOME (I can go and unselect/remove them manually).  There's
still a third set of packages that are associated with the gnome group, but
aren't installed automatically if I choose to install GNOME.

This functionality might be better off in an installer that works at an
application level instead of at a package level.
Comment 5 Richard Hughes 2008-05-07 13:10:37 EDT
We're discussing this on the mailing list at the moment if you want to jump in.
The archive link is here:
http://lists.freedesktop.org/archives/packagekit/2008-May/002999.html
Comment 6 Bug Zapper 2008-05-14 01:45:03 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Robin Norwood 2008-06-09 12:49:30 EDT
*** Bug 450021 has been marked as a duplicate of this bug. ***
Comment 8 John Walicki 2008-07-16 15:32:33 EDT
Richard - The IBM internal enterprise deployment is particularly interested in
the ability to perform a `yum groupinstall "IBM Open Client"`   Our use case is
to install an "IBM Open Client" layer above the distro.  This layer consists of
a variety of yum groups of IBM Lotus products - Notes, Symphony, Sametime and
variety of IBM enterprise integration configurations.  We have defined about 20
yum groups (and matching comps.xml groups).  These internal IBM layers are
deployed to a global internal infrastructure of repository mirrors.

Depending on the business role of the IBMer, they may or may not have a
combination of these 20-odd groups.

We want to programmatically control these roles through calls via dbus to a
PackageKit API.
Comment 9 Richard Hughes 2008-10-27 09:10:32 EDT
Done using collections and a GetCategories group method.
Comment 10 John Walicki 2008-10-29 00:02:22 EDT
I've been following the discussion and implementation of collections in the PackageKit mailing list.  Many thanks to Richard/Tim L for their work in making installation of yum groups easier to handle in Gnome PackageKit.

Note You need to log in before you can comment on or make changes to this bug.