Bug 450021 - There are no keybinding for xfrun4 defined. Unable to add a new binding.
There are no keybinding for xfrun4 defined. Unable to add a new binding.
Status: CLOSED DUPLICATE of bug 435768
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 15:47 EDT by Vincent Graham
Modified: 2008-06-09 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 12:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent Graham 2008-06-04 15:47:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
Pressing ALT+F2 to get the "Run Dialog" (xfrun4) has no result. Noticed that there was no key-binding defined by default for ALT+F2. Created a new pref. by doing:
Settings -> Window Manager Settings -> Keyboard

Once the pref is created, no facility to actually add a new key mapping.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. ALT+F2 - wait... xfrun4 doesn't run.
2. Settings -> Window Manager Settings -> Keyboard, Add a new preference/theme
3. No provisions to actually add a new key mapping. (No add button for keymapping visible)

Actual Results:
xfrun4 does not run. No run dialog appears.

No visible method to add a new key mapping.

Expected Results:
xfrun4 should have run. Should see the run dialog.
Should have a way to define a new keymapping/action.

Additional info:
Comment 1 Kevin Fenzi 2008-06-04 16:31:30 EDT
Per our conversation on IRC, it looks like this was caused by the
xfce-mcs-plugins package not being installed. 

The bug reporter installed Xfce via PackageKit. 
Not sure why some packages in the Xfce group were not installed properly. 

A 'yum groupinstall XFCE' resulted in: 
   1.
      =============================================================================
   2.
       Package                 Arch       Version          Repository        Size
   3.
      =============================================================================
   4.
      Installing:
   5.
       desktop-backgrounds-compat  noarch     9.0.0-1          fedora          
 8.5 k
   6.
       thunar-volman           i386       0.2.0-2.fc9      fedora             84 k
   7.
       xarchiver               i386       0.4.9-0.6.20070103svn24249.fc9  fedora
           394 k
   8.
       xfce-mcs-plugins        i386       4.4.2-4.fc9      fedora            613 k
   9.
       xfce4-appfinder         i386       4.4.2-2.fc9      fedora            245 k
  10.
       xfce4-icon-theme        noarch     4.4.2-1.fc9      fedora            2.0 M
  11.
       xfce4-mailwatch-plugin  i386       1.0.1-8.fc9      fedora            364 k
  12.
       xfwm4-theme-nodoka      noarch     0.1-1.fc9        fedora             21 k
  13.
      Installing for dependencies:
  14.
       arj                     i386       3.10.22-4.fc9    fedora            169 k
  15.
       
  16.
      Transaction Summary
  17.
      =============================================================================
  18.
      Install      9 Package(s)        
  19.
      Update       0 Package(s)        
  20.
      Remove       0 Package(s)        
  21.
       
  22.
      Total download size: 3.9 M

Reassigning over to PackageKit to get looked at... 
Comment 2 Richard Hughes 2008-06-05 04:04:57 EDT
How did you install XFCE?
Comment 3 Vincent Graham 2008-06-07 00:31:44 EDT
I installed it via the gpk-application. I didn't know xfce-mcs-plugins was
missed. I basically selected the xfdesktop package. I hand selected a couple
other packages, but I never removed a dep or anything. I basically migrated from
Gentoo, so I am not that familiar with the YUM command line and hence was not
comfortable with installing it via YUM. Kevin then helped me and walked me
through the process on IRC.
Thanks.
Comment 4 Robin Norwood 2008-06-09 12:49:29 EDT
This is a known issue:

http://fedoraproject.org/wiki/PackageKitFaq#What_about_group_installations_.3F


*** This bug has been marked as a duplicate of 435768 ***

Note You need to log in before you can comment on or make changes to this bug.