Bug 435832 - rpm segfaults on bad options?
rpm segfaults on bad options?
Status: CLOSED DUPLICATE of bug 433324
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-03 22:03 EST by Eric Sandeen
Modified: 2008-03-04 09:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-04 01:10:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2008-03-03 22:03:53 EST
[root@inode test2]# rpm -q rpm
[root@inode test2]# rpm --foobar
Segmentation fault (core dumped)
[root@inode test2]# rpm -Q
Segmentation fault (core dumped)

Testing on an x86 box did not yield the same result.

I don't have all the debuginfo installed, but:

Core was generated by `rpm --foobar'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000031c2682480 in strlen () from /lib64/libc.so.6
(gdb) bt
#0  0x00000031c2682480 in strlen () from /lib64/libc.so.6
#1  0x00000031c264b166 in vfprintf () from /lib64/libc.so.6
#2  0x00000031c264c460 in buffered_vfprintf () from /lib64/libc.so.6
#3  0x00000031c2647886 in vfprintf () from /lib64/libc.so.6
#4  0x00000031c26fbf12 in __fprintf_chk () from /lib64/libc.so.6
#5  0x0000000000404b32 in main (argc=2, argv=<value optimized out>) at
#6  0x00000031c261e36a in __libc_start_main () from /lib64/libc.so.6
#7  0x0000000000403489 in _start ()
Comment 1 Panu Matilainen 2008-03-04 01:10:41 EST

*** This bug has been marked as a duplicate of 433324 ***
Comment 2 Eric Sandeen 2008-03-04 09:30:56 EST
Sorry for the dup; I did a quick search before filing, honest ;)

Note You need to log in before you can comment on or make changes to this bug.