Bug 436063 - I can't sync my pda anymore sony clie, used to work
I can't sync my pda anymore sony clie, used to work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 00:09 EST by Joe Acosta
Modified: 2008-11-26 01:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:18:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of hal-device (114.79 KB, text/plain)
2008-03-05 23:44 EST, Joe Acosta
no flags Details
Patch adds USB_INIT_SONY_CLIE for Sony Clie TJ-37 and SJ-22 (3.68 KB, patch)
2008-09-14 19:45 EDT, Kevin R. Page
no flags Details | Diff

  None (edit)
Description Joe Acosta 2008-03-05 00:09:31 EST
Description of problem:
can't sync sony clie any more

Version-Release number of selected component (if applicable):
Name        : pilot-link                   
Version     : 0.12.2                            
Release     : 18.fc8                        
Build Date: Thu 07 Feb 2008 06:39:16 AM PST


How reproducible:
consistanly always #!%$ arg! this keeps happening, it works then it does not and
then a few months later it stops

Steps to Reproduce:
1. attach clie
2. press sync button
3. start pilot-xfer
4. nothing happens
  
Actual results:
it does not work

Expected results:
it works

Additional info:
usb 1-1: new full speed USB device using uhci_hcd and address 2
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: USB disconnect, address 2
usb 1-1: new full speed USB device using uhci_hcd and address 3
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: USB disconnect, address 3
usb 1-1: new full speed USB device using uhci_hcd and address 4
usb 1-1: device descriptor read/64, error -71
usb 1-1: device descriptor read/64, error -71
usb 1-1: new full speed USB device using uhci_hcd and address 5
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: USB disconnect, address 5
usb 1-1: new full speed USB device using uhci_hcd and address 6
usb 1-1: configuration #1 chosen from 1 choice
Comment 1 Ivana Varekova 2008-03-05 04:42:17 EST
Please 
* could you sync your palm as a root user?
* what is the getfctl output of /dev/bus/usb* - which is attached to your palm?
  (you can find it using command hal-device)
* which type of palm do you use?
thanks.
Comment 2 Joe Acosta 2008-03-05 23:44:07 EST
Created attachment 296999 [details]
output of hal-device

here is the output of hal-device, I'm guessing my device is the sony
Comment 3 Joe Acosta 2008-03-05 23:47:37 EST
I tried as root and it was the same thing.

It is a sony clie tj37.  It used to work.  It is palm OS 5.x

I'm guessing you mean getfacl?  It gives before sync:

getfacl /dev/bus/usb/*
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

# file: dev/bus/usb/002
# owner: root
# group: root
user::rwx
group::r-x
other::r-x


then after sync button pressed, by the way there is no 'beep' like normal when
the sync starts

getfacl /dev/bus/usb/*
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

# file: dev/bus/usb/002
# owner: root
# group: root
user::rwx
group::r-x
other::r-x








Comment 4 Ivana Varekova 2008-03-26 08:55:13 EDT
Please could you try to reproduce this bug with the last pilot-link package:
pilot-link-0.12.3-13.fc9.
Comment 5 Joe Acosta 2008-03-27 23:26:46 EDT
Is it in fc8? 
Comment 6 Alex Lancaster 2008-03-28 01:30:51 EDT
Unfortunately not yet, it is awaiting a new hal and hal-info package to be
pushed in F-8 (bug #434960) but the hal maintainer has yet to respond to the
request.  Then F-8 can probably be updated, see bug #280251 comment #131 for
more details on what is required for proper fix in F-8.
Comment 7 Ivana Varekova 2008-03-28 04:07:40 EDT
I have to agree with Alex, now I'm waiting for hal and hal-info change for fc8,
I'm trying to get in touch with its maintainer but I'm unsuccessful yet. 
Comment 8 Joe Acosta 2008-03-28 12:06:50 EDT
As a work around I found out that I can mount the sd card in my clie as a hard
drive.  So I was able to backup all the data in the pda to the card and then
download what I wanted off the card.  It worked like a usb drive.  

At this time I'm going to wait for the updates and hope you can find the
maintainer, or that someone else can take on the task. 
Comment 9 Kevin R. Page 2008-07-05 21:25:50 EDT
It may transpire that bug #454178 is related: the TJ-37 mentioned in this bug
has a different VID/PID (0x054c/0x0169) to the SJ-22 in bug #454178, but the
TJ-37 doesn't have the USB_INIT_SONY_CLIE flag set in pilot-link HEAD either.

Whatever, it's currently being obscured by permissions issues: the "not working
as root" and getfacl output in comment #3 would seem to contradict, unless
there's both a compatibility _and_ permission issue.

Joe: does pilot-xfer work if you try booting from a Fedora 9 Live CD? This
would, at least temporarily, solve the permissions problem.
Comment 10 Kevin R. Page 2008-07-18 08:52:45 EDT
Joe: pilot-link-0.12.2-21.fc8 has been pushed to the F8 stable repo. Does this
fix your problem? (Or if you've moved to F9, do you still have problems with the
latest updates).

Make sure you remove any hand-modified configuration before you install the
latest updates.

If not I have an idea of what else to try, and can probably create you a patched
RPM if you can't build a patched version yourself?
Comment 11 Joe Acosta 2008-07-28 23:59:17 EDT
ok, just tried as root on fc9 - pilot-link-0.12.3-13.fc9.i386

same thing it does not work
Comment 12 Kevin R. Page 2008-09-14 19:45:50 EDT
Created attachment 316700 [details]
Patch adds USB_INIT_SONY_CLIE for Sony Clie TJ-37 and SJ-22

Joe: could you try installing the following RPM on F9 and letting me know whether it works for your Clie, please?
http://www.krp.myzen.co.uk/pilot-link-0.12.3-15.fc9.i386.rpm

Just trying "pilot-xfer -p usb: -l" should be enough.

If you have an up to date F9 system it should work as non-root; if you're updating it on a LiveCD you'll probably need to be root again to bypass earlier permissions issues.

If you need to rebuild (e.g. for x86_64) the SRPM is here:
http://www.krp.myzen.co.uk/pilot-link-0.12.3-15.fc9.src.rpm


Alex, Ivana: I've rolled Michael's patch from bug #454178 and a new patch for Joe's TJ-37 into the attached patch - it applies to the Fedora CVS F-9 and devel branches. The RPM linked above is a test with the patch applied.

I propose Michael and Joe test it first (and Alex?), and if it's ok you apply to head. Fwiw it works for me, but I don't have a Clie (but it hasn't broken anything for me, not that it should ;)  )
Comment 13 Michael Ekstrand 2008-09-14 21:44:03 EDT
Rebuilt the 0.12.3-15.fc9 SRPM for x86_64 via Mock, and it syncs with my Clie just fine.  Both pilot-xfer -list and PilotManager work.
Comment 14 Ivana Varekova 2008-09-19 06:41:13 EDT
Thanks a lot, Kevin, 
I will wait to Joe respons if he writes it works for him I will add "Sony TJ" part to f9/devel cvs (the first part is in cvs now).
Comment 15 Joe Acosta 2008-09-19 16:18:48 EDT
well this all works now.  problem is that I have not used my pda in so long that it discharged and all the data got wiped out from it.  Including the data on the memory card.  

In any case I got a Nokia N810 and have been using that for the past few months. 

It seems to be working now though.
Comment 16 Ivana Varekova 2008-09-22 02:12:50 EDT
Hello Joe, please which version do you test?
Comment 17 Joe Acosta 2008-09-22 12:06:14 EDT
I used the version at:

http://www.krp.myzen.co.uk/pilot-link-0.12.3-15.fc9.i386.rpm

thanks, 
Joe
Comment 18 Kevin R. Page 2008-09-22 12:26:10 EDT
Joe: thanks, great to know that works.

Ivana: we're good to apply the second part of my patch, right?
Comment 19 Fedora Update System 2008-09-24 05:13:08 EDT
pilot-link-0.12.3-16.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/pilot-link-0.12.3-16.fc9
Comment 20 Ivana Varekova 2008-09-24 05:19:15 EDT
Kevin: Yep, added to pilot-link-0.12.3-18.fc10, pilot-link-0.12.3-16.fc9. 

Joe: could you please test fc9 version ^ ?
Comment 21 Joe Acosta 2008-09-27 20:43:20 EDT
It seems to work and backup the files.
Comment 22 Fedora Update System 2008-09-28 14:44:19 EDT
pilot-link-0.12.3-16.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pilot-link'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8406
Comment 23 Fedora Update System 2008-11-26 01:18:09 EST
pilot-link-0.12.3-16.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.