Bug 436103 - Anaconda displays '-1' as a number of Remaining Packages
Anaconda displays '-1' as a number of Remaining Packages
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Martin Sivák
Alexander Todorov
:
: 436275 (view as bug list)
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-03-05 08:29 EST by Adam Stokes
Modified: 2010-10-22 19:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 03:50:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss of remaining pkgs (2.25 MB, image/bmp)
2008-03-05 10:30 EST, Adam Stokes
no flags Details

  None (edit)
Description Adam Stokes 2008-03-05 08:29:04 EST
Description of problem:
Anaconda displays '-1' as a number of Remaining Packages . This has reproduced
on my xen pv configuration as well. Please refer to the previous post for the
serial console output. I looked in my configuration. After the install (where it
actually showed "Remaining" as "-1", I checked with rpm -qa  | wc -l and sees
that the package exactly adds up to 860 (see another previous post).
Therefore there should be something wrong with the cound on "Completed" .
This is presumably done in textw/progress_text.py:

textw/progress_text.py
    23     def completePackage(self, header, timer):
    24         def formatTime(amt):
    25             hours = amt / 60 / 60
    26             amt = amt % (60 * 60)
    27             min = amt / 60
    28             amt = amt % 60
    29             secs = amt
    30
    31             return "%01d:%02d:%02d" % (int(hours) ,int(min), int(secs))
    32
    33         self.numComplete = self.numComplete + 1



This is called from yuminstall.py:
    96     def callback(self, what, amount, total, h, user):
:
   162         elif what == rpm.RPMCALLBACK_INST_CLOSE_FILE:
   163             po = h
   164             hdr = po.returnLocalHeader()
   165             path = po.returnSimple('relativepath')
   166
   167             nvra = "%s" %(po,)
   168
   169             fn = self.files[nvra].name
   170             self.files[nvra].close()
   171             self.method.unlinkFilename(fn)
   172             self.progress.completePackage(hdr, self.pkgTimer)

Version-Release number of selected component (if applicable):
anaconda 11.x

How reproducible:
100%

Steps to Reproduce:
1. Install system via text mode
2.
3.
  
Actual results:
Remaining displays -1

Expected results:
Show correct number of remaining packages

Additional info:
Comment 1 Adam Stokes 2008-03-05 10:30:18 EST
Created attachment 296884 [details]
ss of remaining pkgs
Comment 2 Chris Lumens 2008-03-28 15:27:01 EDT
*** Bug 436275 has been marked as a duplicate of this bug. ***
Comment 7 RHEL Product and Program Management 2008-06-12 16:28:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Martin Sivák 2008-06-18 07:24:05 EDT
Will be included in 11.1.2.114
Comment 10 Alexander Todorov 2008-10-20 04:54:55 EDT
Adam,
how did you reproduce this? What package selection? I've tried with 5.2 Server and the remaining package count went down to 1 then anaconda executed %post scripts and was ready to reboot. This was with default package selection.
Comment 13 Alexander Todorov 2008-11-11 04:56:42 EST
Adam,
can we get the kickstart file from the customer. We can't reproduce with info what packages were selected for installation.

Note You need to log in before you can comment on or make changes to this bug.