Bug 436161 - JVM error when launching eclipse in rawhide
JVM error when launching eclipse in rawhide
Status: CLOSED DUPLICATE of bug 439683
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-05 13:13 EST by Jesse Keating
Modified: 2013-01-09 22:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 09:42:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
More output (55.44 KB, application/octet-stream)
2008-04-07 06:40 EDT, Paul Black
no flags Details

  None (edit)
Description Jesse Keating 2008-03-05 13:13:19 EST
JVM terminated. Exit code=1
/usr/bin/java
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.2.R331_v20071019/eclipse_1021.so
-startup /usr/share/eclipse/startup.jar
-exitdata ea0024
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar 


$ which javac
/usr/bin/javac
[jkeating@lumos pungi]$ readlink -f `which javac`
/usr/bin/ecj
[jkeating@lumos pungi]$ java -version
java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-b24)
IcedTea 64-Bit Server VM (build 1.7.0-b24, mixed mode)
[jkeating@lumos pungi]$ 


No output from

for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f; done
Comment 1 Andrew Overholt 2008-03-05 14:07:30 EST
Can you try running with the options:  "-debug -consolelog" and attach the
output here?  I can't duplicate in my pseudo rawhide (i386) VM with
3.3.1.1-14.fc9 and IcedTea 24.b24.

Also, there's an upstream bug where upgrades across minor versions require
starting with -clean (this is the reason we stayed with 3.3.0 in F8 and didn't
go to 3.3.1.1 or 3.3.2).  You could try with -clean or with temporarily moving
~/.eclipse out of the way.
Comment 2 Paul Black 2008-04-07 06:39:48 EDT
I seem to be getting this: output from "-debug -consolelog"

Install location:
    file:/usr/share/eclipse/
Configuration file:
    file:/usr/share/eclipse/configuration/config.ini not found or not read
Configuration location:
    file:/home/paul/.eclipse/org.eclipse.platform_3.3.0_1543616141/configuration/
Configuration file:
   
file:/home/paul/.eclipse/org.eclipse.platform_3.3.0_1543616141/configuration/config.ini
not found or not read
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/share/eclipse/plugins/org.eclipse.osgi_3.3.2.R33x_v20080105.jar
Framework classpath:
    file:/usr/share/eclipse/plugins/org.eclipse.osgi_3.3.2.R33x_v20080105.jar
Splash location:
    /usr/share/eclipse/plugins/org.fedoraproject.ide.platform/splash.bmp
Debug options:
    file:/home/paul/.options not found
Time to load bundles: 6
Starting application: 877
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x000000357986a252, pid=3528, tid=2165072
#
# Java VM: OpenJDK 64-Bit Server VM (1.6.0-b08 mixed mode linux-amd64)
# Problematic frame:
# C  [libc.so.6+0x6a252]  fgets+0x32
#
# An error report file with more information is saved as:
# /home/paul/hs_err_pid3528.log
#
# If you would like to submit a bug report, please visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Start VM: /usr/bin/java
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.3.R33x_v20080118/eclipse_1023.so
-startup /usr/share/eclipse/startup.jar
-exitdata 100005
-debug
-consolelog
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar 
Comment 3 Paul Black 2008-04-07 06:40:51 EDT
Created attachment 301496 [details]
More output
Comment 4 Andrew Overholt 2008-04-07 08:36:10 EDT
Lillian:  another/the same OpenJDK bug we have open?
Comment 5 Lillian Angel 2008-04-07 09:42:39 EDT
yes, I have been able to reproduce this on x86_64, but i am not sure why it is
happening

*** This bug has been marked as a duplicate of 439683 ***

Note You need to log in before you can comment on or make changes to this bug.