Bug 439683 - Eclipse crash upon opening file (ref:439529)
Eclipse crash upon opening file (ref:439529)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
: Reopened
: 436161 (view as bug list)
Depends On:
Blocks: F9Target F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-30 08:35 EDT by Dominick Grift
Modified: 2013-01-09 23:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 15:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log related to recent crash (81.90 KB, application/octet-stream)
2008-03-30 08:35 EDT, Dominick Grift
no flags Details
some recovered output from -consolelog (19.95 KB, application/octet-stream)
2008-03-30 08:42 EDT, Dominick Grift
no flags Details
console (42.64 KB, application/octet-stream)
2008-04-03 06:09 EDT, Dominick Grift
no flags Details
hs_err_pid4214.log (88.91 KB, application/octet-stream)
2008-04-03 06:10 EDT, Dominick Grift
no flags Details

  None (edit)
Description Dominick Grift 2008-03-30 08:35:34 EDT
Description of problem:
Eclipse crashes when i complete the "eclipse-slide create a new module" wizard.

Version-Release number of selected component (if applicable):
eclipse-platform-3.3.1.1-17.fc9.x86_64

java-1.6.0-openjdk-plugin-1.6.0.0-0.6.b08.fc9.x86_64
java-1.6.0-openjdk-1.6.0.0-0.6.b08.fc9.x86_64

eclipse-slide-1.3.8-1.fc9.noarch

How reproducible:
Create a new SLIDE project, in that project create a new SLIDE module. complete
module setup wizard. it will crash before you finish.

  
Actual results:
JVM terminated. Exit code=1
/usr/bin/java
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.2.R331_v20071019/eclipse_1021.so
-startup /usr/share/eclipse/startup.jar
-exitdata 1d001c
-clean
-debug
-consolelog
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar 

Expected results:
new frame with new policy module

Additional info:
please see attached log
Comment 1 Dominick Grift 2008-03-30 08:35:34 EDT
Created attachment 299622 [details]
log related to recent crash
Comment 2 Dominick Grift 2008-03-30 08:40:51 EDT
i also recovered some of the output to screen. which is attached below.

i noted this line: 
ERROR: Unable to open policy /home/dgrift/workspace/selinux_modules/base.pp.

which leads me to think this may be eclipse-slide related

please see attached log
Comment 3 Dominick Grift 2008-03-30 08:42:13 EDT
Created attachment 299623 [details]
some recovered output from  -consolelog
Comment 4 Andrew Overholt 2008-03-31 09:26:19 EDT
Lillian/Tom:  do you think this is an OpenJDK bug?
Comment 5 Dominick Grift 2008-04-03 06:08:55 EDT
After today' s updates (April 3) there are some changes to report:

VM terminated. Exit code=1
/usr/bin/java
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.2.R331_v20071019/eclipse_1021.so
-startup /usr/share/eclipse/startup.jar
-exitdata 138016
-clean
-debug
-consolelog
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-XX:MaxPermSize=128m
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar 

Internal errors:

Decoration Calculation
Workbeanch early startup

both: java.lang.ArrayIndexOutOfBoundsExeption

Please see attached logs
Comment 6 Dominick Grift 2008-04-03 06:09:41 EDT
Created attachment 300206 [details]
console
Comment 7 Dominick Grift 2008-04-03 06:10:37 EDT
Created attachment 300207 [details]
hs_err_pid4214.log
Comment 8 Lillian Angel 2008-04-07 09:42:40 EDT
*** Bug 436161 has been marked as a duplicate of this bug. ***
Comment 9 Jesse Keating 2008-04-07 10:15:33 EDT
Lillian, do you believe that there is any chance of getting this fixed for
Fedora 9?  It would really suck to ship with a broken eclipse... :/
Comment 10 Lillian Angel 2008-04-07 10:27:45 EDT
I am looking into it now, I am not entirely sure why it is happening.. but I
will try my best to get it fixed.
Comment 11 Lillian Angel 2008-04-07 13:22:40 EDT
This is definitely a problem with the new eclipse.

I installed java-1.6.0-openjdk on f8 with eclipse-platform-3.3.0-30.fc8 and it
works fine.

If I upgrade eclipse to the version in rawhide, it crashes. Andrew- can you take
a look?
Comment 12 Lillian Angel 2008-04-08 14:41:24 EDT
I am having problems reproducing this now. I have upgraded my system to f9
bundle out now, and everything seems to work fine. I will keep trying.
Comment 13 Dominick Grift 2008-04-08 14:46:20 EDT
I just fixed this by reinstalling Java. It appears that updating packages
corrupted my installation. (ve been getting corrupted kernels and today even
firefox segfaulted) enabled smart and ran smarctl but passed test and no
reallocations reported.

Sorry for the inconvenience and that it took so long for me to get where i am
Comment 14 Jesse Keating 2008-04-08 15:09:20 EDT
Hrm, I'm not having corruption issues, but still having open issues.  Perhaps I
need to setup some test cases of a F8 install with icedtea and eclipse working,
then upgraded to F9...
Comment 15 Jesse Keating 2008-04-08 15:30:35 EDT
Blah, seems one of the recent eclipse or java builds has fixed this.  Closing again.

Note You need to log in before you can comment on or make changes to this bug.