Bug 436209 - Resources tab graphs unclear and blurred and causes high cpu load
Summary: Resources tab graphs unclear and blurred and causes high cpu load
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-system-monitor (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 437255 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-05 21:38 UTC by Andrew Farris
Modified: 2018-04-11 11:43 UTC (History)
3 users (show)

Fixed In Version: gnome-system-monitor-2.22.0-1.fc9.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 01:19:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rawhide-testing/Screenshot.png (310.91 KB, image/png)
2008-03-11 22:40 UTC, Andrew Farris
no flags Details

Description Andrew Farris 2008-03-05 21:38:11 UTC
Description of problem:
The gnome-system-monitor resources tab has 3 horizontal graphs.  On my system
for awhile now I've had this tab cause 100% cpu usage (by gnome-system-monitor)
and the graphs are terribly misshapen, blurred, and replicated (see screenshot). 

I believe there was some discussion on this (I remember posting this screenshot)
but cannot find where it was (may have been an upstream bug, something about the
new graph style and image rendering?).

Version-Release number of selected component (if applicable):
gnome-system-monitor-2.21.92-1.fc9.i386

How reproducible:
Every time it is opened.

Steps to Reproduce:
1. 
  
Actual results:
view resources tab, wait for a few seconds to see graphs update incorrectly

Expected results:
view resources tab, see clear, unblurred graphs

Comment 1 Andrew Farris 2008-03-05 21:59:26 UTC
I found the discussion:
https://www.redhat.com/archives/fedora-test-list/2008-February/msg00366.html

And upstream bug mentioned there:
http://bugzilla.gnome.org/show_bug.cgi?id=328101

Comment 2 Andrew Farris 2008-03-11 22:40:06 UTC
Created attachment 297681 [details]
rawhide-testing/Screenshot.png

Screenshot of this issue, graphs being drawn incorrectly.

Comment 3 Matěj Cepl 2008-03-13 16:03:52 UTC
*** Bug 437255 has been marked as a duplicate of this bug. ***

Comment 4 Michael Schwendt 2008-03-14 20:33:26 UTC
Is this about "100% cpu usage" or about "unclear/blurred graphs"?

Comment 5 Andrew Farris 2008-03-14 20:48:59 UTC
They are (as far as available info so far indicates) related issues.  The upstream bug has discussion on CPU 
usage for drawing the graphs as well as issues of the rendering done incorrectly.  I think part of the 
problem was that the patches that introduced the new graph drawing style caused huge cpu load because 
too many data points were used when the graphs were not very high?

Anyway, both things occur at once right now.  The high CPU load usually stops after a short period but the 
graphs remain messed up.  If you change tabs to the process list and then back to the resources graphs 
the CPU load will return for awhile and then stop, and the graphs are still messed up.

I'm willing to work on this but not really sure how to try and figure out how these are related problems.

Comment 6 Andrew Farris 2008-04-06 01:19:55 UTC
Appears to be fixed in gnome-system-monitor-2.22.0-1.fc9.i386.  Both high load
and blurry graph drawing.


Note You need to log in before you can comment on or make changes to this bug.