Bug 436242 - F9 KDE4 System Tray - Unidentified object
F9 KDE4 System Tray - Unidentified object
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 446581 447103 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 21:30 EST by Gerald Cox
Modified: 2008-05-17 23:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 13:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unidentified object between nm-applet and kpowersave (12.91 KB, image/png)
2008-03-05 21:31 EST, Gerald Cox
no flags Details
Invalid gtk icon (7.75 KB, image/png)
2008-04-07 02:18 EDT, Gilboa Davara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 155381 None None None Never

  None (edit)
Description Gerald Cox 2008-03-05 21:30:34 EST
Description of problem:
When starting KDE4 more often than not and unidentifiable object appears in the
system tray.  You cannot select the object.  Sometimes it appears large,
sometimes small.  I have taken a snapshot and attached. 



Version-Release number of selected component (l applicable):
kdebase-4.0.2-2.fc9.x86_64


How reproducible:
start kde, object appears in system tray


Steps to Reproduce:
1. start kde, object appears in system tray
2.
3.
  
Actual results:
object appears in system tray.  Object is not selectable for more information.


Expected results:
No unidentified objects appear.  All objects are clickable for more information.

Additional info:
Comment 1 Gerald Cox 2008-03-05 21:31:55 EST
Created attachment 296982 [details]
Unidentified object between nm-applet and kpowersave
Comment 2 Rex Dieter 2008-03-05 21:43:16 EST
It's likely sealert that hides itself, but apparently, not too well (in
combination with kde4's workarounds for gtk lacking argb support for systray icons).
Comment 3 Gerald Cox 2008-03-14 09:51:38 EDT
Interesting to note:  the last few days the problem went away with system
updates.  I rebooted my system over and over again, and i couldn't reproduce. 
Today, I applied the updates below and the problem has returned... and it occurs
on every reboot... hope this offers an additional clue.  

Mar 14 06:21:02 Updated: xorg-x11-server-common-1.4.99.901-8.20080310.fc9.x86_64
Mar 14 06:21:05 Updated: xorg-x11-server-Xorg-1.4.99.901-8.20080310.fc9.x86_64
Mar 14 06:21:06 Updated: xorg-x11-drv-i810-2.2.1-12.fc9.x86_64
Mar 14 06:21:08 Updated: fedora-release-8.92-1.noarch
Mar 14 06:21:22 Updated: system-config-services-0.99.9-1.fc9.noarch
Mar 14 06:21:23 Updated: pyxf86config-0.3.37-1.fc9.x86_64
Mar 14 06:21:29 Updated: pirut-1.3.30-2.fc9.noarch
Comment 4 Mary Ellen Foster 2008-03-29 17:48:47 EDT
I still see this in the F9 KDE live image. My picture looks basically like the
attachment. Moving the panel around the screen a bit eventually made it go away.
Comment 5 Adrian "Adi1981" P. 2008-04-02 13:39:51 EDT
Also got it on fully updated rawhide, right now i've got 4 unidentified objects
in kde tray.
Comment 6 Gilboa Davara 2008-04-07 02:18:05 EDT
Created attachment 301467 [details]
Invalid gtk icon

It seems that GTK icons are either cut (instead of resized) or trashed.
(image attached)
Still getting it in 4.0.3.

- Gilboa
Comment 7 Rex Dieter 2008-04-07 07:41:59 EDT
comment upstream please ( http://bugs.kde.org/155381 ).
Comment 8 Kevin Kofler 2008-05-15 06:15:17 EDT
*** Bug 446581 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Kofler 2008-05-17 23:02:27 EDT
*** Bug 447103 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.