Bug 436276 - No network devices for "Shared physical device" option
No network devices for "Shared physical device" option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
All Linux
urgent Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
GSSApproved
: ZStream
: 436279 440482 (view as bug list)
Depends On:
Blocks: 436362 436755
  Show dependency treegraph
 
Reported: 2008-03-06 05:28 EST by Alexander Todorov
Modified: 2010-10-22 19:04 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2008-0480
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen dump of UI (24.56 KB, image/png)
2008-03-06 05:28 EST, Alexander Todorov
no flags Details
screen dump from RHEL5.1 machine where this works (34.03 KB, image/png)
2008-03-06 05:29 EST, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-03-06 05:28:02 EST
Description of problem:
Using virt-manager UI to create a paravirtual guest there are no available
network devices under "Shared physical device" option. Only "Virtual network"
option is possible.

Version-Release number of selected component (if applicable):
virt-manager-0.5.3-2.el5

How reproducible:
100%

Steps to Reproduce:
1. Start virt-manager
2. Create new guest and navigate to network settings screen
3. Choose "Shared physical device" option
  
Actual results:
No devices present. Install can't continue

Expected results:
Device xenbr0 is present and can be chosen.

Additional info:
ifconfig output from the system

eth0      Link encap:Ethernet  HWaddr 00:1A:4B:0C:88:3B  
          inet addr:10.12.5.42  Bcast:10.12.7.255  Mask:255.255.252.0
          inet6 addr: fe80::21a:4bff:fe0c:883b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4003 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2140 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:304077 (296.9 KiB)  TX bytes:293840 (286.9 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:32 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3624 (3.5 KiB)  TX bytes:3624 (3.5 KiB)

peth0     Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:4159 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2152 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:329773 (322.0 KiB)  TX bytes:303174 (296.0 KiB)
          Interrupt:17 

vif0.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:2141 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4003 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:294002 (287.1 KiB)  TX bytes:304077 (296.9 KiB)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:8894 (8.6 KiB)

xenbr0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:1446 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:89000 (86.9 KiB)  TX bytes:0 (0.0 b)
Comment 1 Alexander Todorov 2008-03-06 05:28:02 EST
Created attachment 297021 [details]
screen dump of UI
Comment 2 Alexander Todorov 2008-03-06 05:29:36 EST
Created attachment 297022 [details]
screen dump from RHEL5.1 machine where this works

ifconfig output from RHEL5.1 machine where this works.

eth0	  Link encap:Ethernet  HWaddr 00:16:41:E4:1D:63  
	  inet addr:10.34.32.137  Bcast:10.34.35.255  Mask:255.255.252.0
	  inet6 addr: fec0::f101:216:41ff:fee4:1d63/64 Scope:Site
	  inet6 addr: fe80::216:41ff:fee4:1d63/64 Scope:Link
	  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	  RX packets:51286 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:27623 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0 
	  RX bytes:22494169 (21.4 MiB)	TX bytes:2958076 (2.8 MiB)

lo	  Link encap:Local Loopback  
	  inet addr:127.0.0.1  Mask:255.0.0.0
	  inet6 addr: ::1/128 Scope:Host
	  UP LOOPBACK RUNNING  MTU:16436  Metric:1
	  RX packets:26814 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:26814 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0 
	  RX bytes:12032357 (11.4 MiB)	TX bytes:12032357 (11.4 MiB)

peth0	  Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
	  inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
	  UP BROADCAST RUNNING NOARP  MTU:1500	Metric:1
	  RX packets:98576 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:61198 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000 
	  RX bytes:85592144 (81.6 MiB)	TX bytes:5543929 (5.2 MiB)
	  Base address:0x3000 Memory:ee000000-ee020000 

vif0.0	  Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
	  inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
	  UP BROADCAST RUNNING NOARP  MTU:1500	Metric:1
	  RX packets:27623 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:51286 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0 
	  RX bytes:2958076 (2.8 MiB)  TX bytes:22494169 (21.4 MiB)

vif1.0	  Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
	  inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
	  UP BROADCAST RUNNING NOARP  MTU:1500	Metric:1
	  RX packets:33538 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:49961 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:32 
	  RX bytes:1855904 (1.7 MiB)  TX bytes:63262792 (60.3 MiB)

virbr0	  Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
	  inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
	  inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
	  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0 
	  RX bytes:0 (0.0 b)  TX bytes:468 (468.0 b)

xenbr0	  Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
	  inet6 addr: fec0::f101:fcff:ffff:feff:ffff/64 Scope:Site
	  inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
	  UP BROADCAST RUNNING NOARP  MTU:1500	Metric:1
	  RX packets:21591 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0 
	  RX bytes:2139444 (2.0 MiB)  TX bytes:0 (0.0 b)
Comment 3 Alexander Todorov 2008-03-06 05:32:52 EST
Dan,
is this a regression?

What I can see from ifconfig dump is that xenbr0 doesn't have an address on the
machine where that bug happens. Both machines are using DHPC.
Comment 4 Alexander Todorov 2008-03-06 05:44:48 EST
Dan,
I have the following in virt-manager.log right after the application starts even
before doing anything else.

[Thu, 06 Mar 2008 05:42:38 virt-manager 5692] ERROR (connection:156) Unable to
connect to HAL to list network devices: '%s'dbus_bindings.DBusException A
security policy in place prevents this sender from sending this message to this
recipient, see message bus configuration file (rejected message had interface
"(unset)" member "QueryCapability" error name "(unset)" destination
"org.freedesktop.Hal")
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 153, in
detect_network_devices
    self._device_added(path)
  File "/usr/share/virt-manager/virtManager/connection.py", line 164, in
_device_added
    if obj.QueryCapability("net"):
  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 25, in __call__
    ret = self._proxy_method (*args, **keywords)
  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 102, in __call__
    reply_message = self._connection.send_with_reply_and_block(message, timeout)
  File "dbus_bindings.pyx", line 455, in
dbus_bindings.Connection.send_with_reply_and_block
DBusException: A security policy in place prevents this sender from sending this
message to this recipient, see message bus configuration file (rejected message
had interface "(unset)" member "QueryCapability" error name "(unset)"
destination "org.freedesktop.Hal")


I have SELinux in permissive mode. Is that the root cause of the problem or it's
another bug?
Thanks.
Comment 5 Daniel Berrange 2008-03-06 08:08:07 EST
This is a regression caused by the recent DBus security errata.

We will need to z-stream this fix too :-(
Comment 6 RHEL Product and Program Management 2008-03-06 08:20:32 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 7 Daniel Berrange 2008-03-06 10:25:36 EST
Upstream change to address this issue is

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=43d82ba67ffa 


Should be possible to backport this to 5.1.x and 5.2 virt-manager releases
without any trouble.
Comment 8 Bill Burns 2008-03-06 10:30:42 EST
Set dev ack.
Comment 9 Bill Burns 2008-03-06 10:31:10 EST
set beta target
Comment 11 Daniel Berrange 2008-03-06 11:23:53 EST
Fix from upstream is backported & built for 5.2 in

$ brew latest-pkg dist-5E-qu-candidate virt-manager
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.5.3-3.el5                  dist-5E-qu-candidate  berrange
Comment 13 Bill Burns 2008-03-06 14:34:00 EST
Requesting z-stream. BZ was already cloned by mistake. We will take care of
duping it when the new bz is created...
Comment 18 Cole Robinson 2008-03-11 11:40:13 EDT
*** Bug 436279 has been marked as a duplicate of this bug. ***
Comment 19 Gianluca Sforna 2008-04-01 10:45:44 EDT
Is this the same as http://bugs.centos.org/view.php?id=2516 ?
Comment 20 Alexander Todorov 2008-04-01 10:56:44 EDT
Gianluca,
I think so. That was caused by a HAL bug I believe.
Comment 21 Daniel Berrange 2008-04-01 11:07:35 EDT
The problem was caused by the recent DBus security errata which caused various
DBus API calls to be rejected. We had to change the way we handled DBus in
virt-manager
Comment 22 David Mair 2008-04-08 15:16:24 EDT
*** Bug 440482 has been marked as a duplicate of this bug. ***
Comment 24 errata-xmlrpc 2008-05-21 13:29:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0480.html

Note You need to log in before you can comment on or make changes to this bug.