Bug 436401 (TB35871046) - TB35871046 IsdnInterface.py:162:setup:AttributeError: 'module' object has no attribute 'card'
Summary: TB35871046 IsdnInterface.py:162:setup:AttributeError: 'module' object has no ...
Status: CLOSED DUPLICATE of bug 416821
Alias: TB35871046
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: 8
Hardware: i586
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-06 22:21 UTC by Bernd Fomferra
Modified: 2008-04-07 13:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 13:47:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debuginfo (882 bytes, text/plain)
2008-03-06 22:21 UTC, Bernd Fomferra
no flags Details

Description Bernd Fomferra 2008-03-06 22:21:24 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.network Configuration->new
2.Isdn->forward
3.Crash
  
Actual results:


Expected results:


Additional info:
ISDN Card: AVM B1 Pcmcia

Comment 1 Bernd Fomferra 2008-03-06 22:21:24 UTC
Created attachment 297115 [details]
Debuginfo

Comment 2 swinkerz 2008-03-14 21:22:37 UTC
(In reply to comment #0)
> Description of problem:
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.network Configuration->new
> 2.Isdn->forward
> 3.Crash
>   
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:
> ISDN Card: AVM B1 Pcmcia

Same problem also for me, i tried to create a new ISDN Device for a Asuscom ISDN
PCI and this is the output, hope could help:

Component: system-config-network
Version: 1.4.7
Summary: TB35871046 IsdnInterface.py:162:setup:AttributeError: 'module' object
has no attribute 'card'

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 121, in on_start_page_next
    druid_pages = interface.get_druids()
  File "/usr/share/system-config-network/netconfpkg/gui/IsdnInterface.py", line
105, in get_druids
    if not self.init_gui():
  File "/usr/share/system-config-network/netconfpkg/gui/IsdnInterface.py", line
74, in init_gui
    self.setup()
  File "/usr/share/system-config-network/netconfpkg/gui/IsdnInterface.py", line
162, in setup
    cardlist = NCisdnhardware.card.keys()
AttributeError: 'module' object has no attribute 'card'

Local variables in innermost frame:
self: <netconfpkg.gui.IsdnInterface.IsdnInterface instance at 0x14c2e60>

Comment 3 Paul Bolle 2008-04-07 12:21:58 UTC
This is basically the same problem as Bug 416821, which crashes with:
"[...]
self.setup()
  File "/usr/share/system-config-network/netconfpkg/gui/isdnhardware.py", line
207, in setup
    cardlist = NCisdnhardware.card.keys()
AttributeError: 'module' object has no attribute 'card'"

So this bug could be closed as a duplicate (which I seem not allowed to do). 

Comment 4 Harald Hoyer 2008-04-07 13:47:33 UTC

*** This bug has been marked as a duplicate of 416821 ***


Note You need to log in before you can comment on or make changes to this bug.