Bug 436506 - DRM cannot be initialized
DRM cannot be initialized
Status: CLOSED DUPLICATE of bug 433728
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-07 12:03 EST by Peter Janakiev
Modified: 2008-03-10 15:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-10 15:51:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg log file (45.15 KB, text/plain)
2008-03-08 10:10 EST, Peter Janakiev
no flags Details

  None (edit)
Description Peter Janakiev 2008-03-07 12:03:24 EST
Description of problem:
With the new update of Xserver/Kernel the DRM cannot be initilized and thus no
direct rendering on the Intel855GM card.

Version-Release number of selected component (if applicable):

How reproducible:
Always, even without a config file 

Steps to Reproduce:
1.Start the X server
2.issue glxinfo in terminal
Actual results:
NO direct rendering

Expected results:
Direct rendering enabled

Additional info:
(II) intel(0): [DRI] installation complete
(II) intel(0): [drm] dma control initialized, using IRQ 10
(II) intel(0): direct rendering: Enabled
(II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(EE) intel(0): Could not initialize the DRM memory manager.
(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0xeea6d000 at 0xb7fbe000
(II) intel(0): [drm] Closed DRM master.
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)
Comment 1 Matěj Cepl 2008-03-07 12:31:49 EST
Could we get full /var/log/Xorg.0.log attached to this bug please as a
uncompressed attachment?
Comment 2 Peter Janakiev 2008-03-08 10:11:00 EST
Created attachment 297304 [details]
Xorg log file

Here it is. I don't know on which update exactly this happened because I
usually do not use compiz/GL apps. But this laptop used to work very well with
compiz - i have demoed mplayer with video plugin for friends so I am sure it
was working.
Comment 3 Peter Janakiev 2008-03-09 07:31:56 EDT
The issue is caused by the kernel side, with the older kernel direct rendering
works great:

This works: Linux localhost.localdomain #1 SMP Sun Feb 10
17:48:34 EST 2008 i686 i686 i386 GNU/Linux
The latest update does not. probably the kernel driver side.
Comment 4 Chuck Ebbert 2008-03-10 15:51:00 EDT

*** This bug has been marked as a duplicate of 433728 ***

Note You need to log in before you can comment on or make changes to this bug.