This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 433728 - Compiz won't start with kernel-2.6.24.2-7.fc8.i686
Compiz won't start with kernel-2.6.24.2-7.fc8.i686
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 434151 436498 436506 436513 436667 436723 436728 436871 437234 437241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 20:32 EST by Bojan Smojver
Modified: 2008-04-08 22:21 EDT (History)
16 users (show)

See Also:
Fixed In Version: 2.6.24.3-34.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 15:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output. (30.26 KB, text/plain)
2008-03-05 19:20 EST, Kevin Fenzi
no flags Details
Xorg.0.log (38.44 KB, text/plain)
2008-03-05 19:21 EST, Kevin Fenzi
no flags Details
dmesg output on Dell Inspiron 6400, kernel 2.6.24.3-18.fc8 (24.81 KB, text/plain)
2008-03-05 19:28 EST, Bojan Smojver
no flags Details
X log on Dell Inspiron 6400, kernel 2.6.24.3-18.fc8 (40.34 KB, text/plain)
2008-03-05 19:29 EST, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2008-02-20 20:32:23 EST
Description of problem:
Compiz won't start on with this kernel. Error message is:

$ compiz
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0


Version-Release number of selected component (if applicable):
2.6.24.2-7.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Start GNOME with Compiz configured.
2. See window manager not come up.
3. Start terminal, try running compiz from there, see error.
  
Actual results:
Compiz fails.

Expected results:
Works with 2.6.23.15-137.fc8.
Comment 1 Chuck Ebbert 2008-02-21 19:05:41 EST
Can you post the output of the 'lspci -nn' command?
Comment 2 Bojan Smojver 2008-02-21 19:42:41 EST
-------------------
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML
and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME,
943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High
Definition Audio Controller [8086:27d8] (rev 01)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 1 [8086:27d0] (rev 01)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 4 [8086:27d6] (rev 01)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 [8086:27c8] (rev 01)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 [8086:27c9] (rev 01)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 [8086:27ca] (rev 01)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 [8086:27cb] (rev 01)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller [8086:27cc] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448]
(rev e1)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface
Bridge [8086:27b9] (rev 01)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA
IDE Controller [8086:27c4] (rev 01)
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller
[8086:27da] (rev 01)
03:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX
[14e4:170c] (rev 02)
03:01.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller
[1180:0832]
03:01.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host
Adapter [1180:0822] (rev 19)
03:01.2 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host
Adapter [1180:0592] (rev 01)
03:01.3 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller
[1180:0852] (rev 0a)
0b:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG
Network Connection [8086:4222] (rev 02)
-------------------

This is a Dell Inspiron 6400 notebook.
Comment 3 Ian Malone 2008-02-22 10:13:01 EST
Seeing the same here (N.B I must boot with ec_intr to get it started at all,
#432477).
http://smolt.fedoraproject.org/show?UUID=856ddbe0-4ed8-43f7-a459-78715a9957cf

$ /sbin/lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML
and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME,
943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High
Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 2 [8086:27d2] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 3 [8086:27d4] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 4 [8086:27d6] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448]
(rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface
Bridge [8086:27b9] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE
Controller [8086:27df] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA
IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller
[8086:27da] (rev 02)
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8036 PCI-E
Fast Ethernet Controller [11ab:4351] (rev 16)
06:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG
Network Connection [8086:4222] (rev 02)
0a:03.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller
[104c:8039]
0a:03.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant
IEEE 1394 Host Controller [104c:803a]
0a:03.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card
Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
[ian@prometheus ~]$ /sbin/lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML
and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME,
943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High
Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 2 [8086:27d2] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 3 [8086:27d4] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express
Port 4 [8086:27d6] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448]
(rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface
Bridge [8086:27b9] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE
Controller [8086:27df] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA
IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller
[8086:27da] (rev 02)
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8036 PCI-E
Fast Ethernet Controller [11ab:4351] (rev 16)
06:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG
Network Connection [8086:4222] (rev 02)
0a:03.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller
[104c:8039]
0a:03.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant
IEEE 1394 Host Controller [104c:803a]
0a:03.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card
Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]
Comment 4 Chuck Ebbert 2008-02-22 13:17:24 EST
*** Bug 434151 has been marked as a duplicate of this bug. ***
Comment 5 Sammy 2008-02-22 14:37:19 EST
Is anyone using propriety graphics/gl drivers? The 2.6.24 is not exporting
some symbols that seem to be used by some propriety drivers.
Comment 6 Bojan Smojver 2008-02-22 16:25:20 EST
I'm using Fedora supplied Intel driver.
Comment 7 Bojan Smojver 2008-02-26 19:41:42 EST
I see the new stable kernel has been built:

http://koji.fedoraproject.org/koji/buildinfo?buildID=39997

Is it worth trying regarding this issue?
Comment 8 Ian Malone 2008-02-27 18:18:12 EST
Public smolt UUID as private ones no-longer work:

http://www.smolts.org/client/show?uuid=pub_1f3e90d3-38fa-4691-970a-60a4f998d9a0
Comment 9 Bojan Smojver 2008-03-02 19:31:25 EST
Still borked in 2.6.24.3-12.fc8.
Comment 10 Dave Jones 2008-03-05 18:36:20 EST
can you attach dmesg output please, and the /var/log/Xorg.log too ?
Comment 11 Kevin Fenzi 2008-03-05 19:20:50 EST
Created attachment 296962 [details]
dmesg output.
Comment 12 Kevin Fenzi 2008-03-05 19:21:30 EST
Created attachment 296963 [details]
Xorg.0.log

Xorg.0.log
Comment 13 Kevin Fenzi 2008-03-05 19:22:11 EST
I have attached my Xorg.0.log and dmesg. 
Hope it helps... happy to provide further info. 
Comment 14 Bojan Smojver 2008-03-05 19:28:26 EST
Created attachment 296964 [details]
dmesg output on Dell Inspiron 6400, kernel 2.6.24.3-18.fc8
Comment 15 Bojan Smojver 2008-03-05 19:29:29 EST
Created attachment 296966 [details]
X log on Dell Inspiron 6400, kernel 2.6.24.3-18.fc8
Comment 16 Bojan Smojver 2008-03-05 19:32:57 EST
This seems to be the key from X log:

(II) AIGLX: Screen 0 is not DRI capable
Comment 17 Bojan Smojver 2008-03-05 19:40:55 EST
Also, possibly this:

(EE) intel(0): Could not initialize the DRM memory manager.
(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0xf8b12000 at 0xb7f3b000
(II) intel(0): [drm] Closed DRM master.
Comment 18 Bojan Smojver 2008-03-05 19:44:22 EST
Difference in dmesg seem to be as follows:

dmesg of the kernel that works (2.6.23.15-137.fc8):
----------------------------
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized i915 1.6.0 20060119 on minor 0
----------------------------

dmesg of the kernel that doesn't work:
----------------------------
[drm] Initialized drm 1.1.0 20060810
PCI: Setting latency timer of device 0000:00:02.0 to 64
[drm] Initialized i915 1.11.0 20071122 on minor 0
CPU0 attaching NULL sched-domain.
CPU1 attaching NULL sched-domain.
CPU0 attaching sched-domain:
 domain 0: span 00000003
  groups: 00000001 00000002
CPU1 attaching sched-domain:
 domain 0: span 00000003
  groups: 00000002 00000001
----------------------------
Comment 19 Bojan Smojver 2008-03-05 19:51:16 EST
Maybe we need xorg-x11-drv-i810-2.2.1?
Comment 20 Andrew Duggan 2008-03-05 23:08:35 EST
No problem with any 2.6.24.x kernels using the i810 driver.  Compiz starts fine
no errors DELL E1505 (same as a 6400).  
Comment 21 Kevin Fenzi 2008-03-06 15:21:07 EST
In reply to comment #20: 

If you switch to the 'intel' driver does it fail the same way for you? 
Or do you mean you are using the i810 package (which has both the intel and i810
drivers in it)
Comment 22 Andrew Duggan 2008-03-06 15:44:28 EST
In reply to #21 

Yes if I switch my xorg.conf to use the intel driver instead of i180 then it
breaks the same way. Compiz won't start and I get
(EE) intel(0): Could not initialize the DRM memory manager
in the Xorg.0.log

I used the i810 because its the only way I can get xv with totem to work or get
mplayer to run without eating up an entire core of the cpu.

One odd thing I did notice is that the machine locks up if I restart the x
server with the i810 on 2.6.24.x (but I don't do that much)

Comment 23 Bojan Smojver 2008-03-06 17:38:20 EST
I see this in the changelog of the kernel being built in koji:

-------------------------------
* Thu Mar 06 2008 Dave Airlie <airlied@redhat.com> 2.6.24.3-19
- fixup agp/drm patches for F8 kernel
-------------------------------

Is that related to this bug?
Comment 24 Chuck Ebbert 2008-03-06 18:38:05 EST
(In reply to comment #23)
> I see this in the changelog of the kernel being built in koji:
> 
> -------------------------------
> * Thu Mar 06 2008 Dave Airlie <airlied@redhat.com> 2.6.24.3-19
> - fixup agp/drm patches for F8 kernel
> -------------------------------
> 
> Is that related to this bug?

We hope so.  :)

Please test it.
Comment 25 Kevin Fenzi 2008-03-06 20:17:25 EST
Success... 

kernel-2.6.24.3-21.fc8.x86_64

seems to work normally here... ;)
Comment 26 Bojan Smojver 2008-03-06 20:59:24 EST
Yep, I can confirm this too - works now with 2.6.24.3-21.fc8.
Comment 27 Konstantin Ryabitsev 2008-03-06 21:33:46 EST
Confirmed on a mac mini i686 as well -- works like a charm.
Comment 28 Dave Jones 2008-03-07 12:52:32 EST
*** Bug 436513 has been marked as a duplicate of this bug. ***
Comment 29 Fedora Update System 2008-03-07 14:24:15 EST
kernel-2.6.24.3-22.fc8 has been submitted as an update for Fedora 8
Comment 30 Thomas J. Baker 2008-03-07 20:45:49 EST
Something still isn't quite right. With the 2.6.24.3-22 kernel I do get direct
rendering but there's something up with the colors. One example is the
SmoothWeather screenlet. It has a color and opacity gradient from top to bottom
and with 2.6.23.15-137 kernel it draws correctly. With the 2.6.24.3-22, there is
no gradient, just the starting color halfway and then the ending color the other
half. Bringing up the radar on the screenlet also draws a garbled mess.
Switching only the kernel makes it work correctly or not.

I can provide screenshots if it would help. I'll try to find other, maybe more
common, ways to make the problem appear.
Comment 31 Thomas J. Baker 2008-03-07 20:47:08 EST
I should have added that this is on x86_64 and I have

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA
controller])
Comment 32 Thomas J. Baker 2008-03-07 21:48:13 EST
With my wife's XPS1330, I don't have the color problem. Still x86_64 but 

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated
Graphics Controller (rev 0c)
Comment 33 Eelco Hoekema 2008-03-08 05:09:54 EST
With kernel 2.6.24.3-22, the problem is solved for me as well. (Though i do get
an error early at startup now: "i8042.c: Controller not found".)
Comment 34 Thomas J. Baker 2008-03-08 09:15:13 EST
Upgrading the version of the screenlet from 0.3 to 0.3.1 makes it draw correctly
with the new kernel on my XPSM1210. Strange though that the old one draws
correctly with the old kernel. 
Comment 35 Matěj Cepl 2008-03-10 14:34:59 EDT
*** Bug 436667 has been marked as a duplicate of this bug. ***
Comment 36 Chuck Ebbert 2008-03-10 15:51:01 EDT
*** Bug 436506 has been marked as a duplicate of this bug. ***
Comment 37 Chuck Ebbert 2008-03-10 15:51:22 EDT
*** Bug 436498 has been marked as a duplicate of this bug. ***
Comment 38 Fedora Update System 2008-03-13 17:58:16 EDT
kernel-2.6.24.3-34.fc8 has been submitted as an update for Fedora 8
Comment 39 Fedora Update System 2008-03-16 15:27:42 EDT
kernel-2.6.24.3-34.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 Chuck Ebbert 2008-03-18 14:52:50 EDT
*** Bug 437234 has been marked as a duplicate of this bug. ***
Comment 41 Chuck Ebbert 2008-03-18 14:53:11 EDT
*** Bug 437241 has been marked as a duplicate of this bug. ***
Comment 42 Chuck Ebbert 2008-03-18 14:54:24 EDT
*** Bug 436723 has been marked as a duplicate of this bug. ***
Comment 43 Chuck Ebbert 2008-03-19 15:55:31 EDT
*** Bug 436728 has been marked as a duplicate of this bug. ***
Comment 44 Dave Airlie 2008-04-08 22:21:38 EDT
*** Bug 436871 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.